Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

With our new 21,5"-iMac, we bought the first Mac system for our Windows/Linux-oriented office. Hence we don’t have a lot of experience in using Mac OS X.

I started to set up everything and it ran quite well so far until I reached the configuration of our network printers. In our company we use a Linux system running a CUPS-server. This server holds the configuration of all queues. All changes regarding settings or even additional printers are made there.

As we do not want to make changes on every client system if new printers join the infrastructure, we forward all print jobs to the remote CUPS print server. This saves a lot of time instead of configuring printers via IPP or equivalent.

To make this work on Mac OS X, I found a link with the information I needed: http://hints.macworld.com/article.php?story=2004011920201534

The .cupsrc-file (hidden file) in the home directory containing the line

ServerName <myserver>

will instruct the local CUPS system to receive remote print queues from our print server.

After saving the file, the GUI configuration tool for printers in Mac OS X (System Preferences… -> Print & Fax) shows all remote queues running on the central CUPS server.

But after I upgraded to Mac OS X 1.7 “Lion”, the GUI doesn’t show the queues anymore. I have no idea what to do and even Apple Support (registered owner of CUPS system) couldn’t help me out with that. They only pointed to the CUPS configuration file (/etc/cups/cupsd.conf), but I do not know the right setting there for printing to remote queues. Also, the web interface running on localhost:631 couldn’t help me… Any ideas?

share|improve this question

2 Answers 2

The release notes for CUPS 1.5 mention that

CUPS no longer supports the old ~/.cupsrc or ~/.lpoptions files from CUPS 1.1.x. The ~/.cups/client.conf and ~/.cups/lpoptions files that were introduced in CUPS 1.2 must now be used.

Have you tried putting the line

ServerName print-server

into ~/.cups/client.conf?

share|improve this answer
    
yes, I tried to move the 'client.conf' file to to '.cups/' directory inside my home directory.. Doesn't seem to work! Is there a possible central setting for all users running this machine? –  Master of Celebration Jul 29 '11 at 12:38
    
Yeah, I'm having the same issue, and I've already had the files name correctly. What I think our particular issues is though is that our old Linux CUPS server running v1.1 can no longer work with the CUPS 1.5 client on the Lion machines. –  user9617 Aug 9 '11 at 19:39

Set up /etc/cups/client.conf correctly for your environment so that the cups printers display in the print config dialog.

To get the queues to display in the applications as a choice, make each printer the default printer once. Distribute the resulting com.apple.print.favorites.plist to users with mcx or copy to ~/Library/Preferences

It uses the PPDs on the server. No client config necessary!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.