Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I submitted the following as a Xcode bug report, but I'm post it here in case somebody is experiencing the same problem and can shed more light into the matter.

I use two devices for development: my iPhone 3GS, and a friend's iPhone 3G running 4.2.1/8C148. I could debug with both of these devices using Snow Leopard and Xcode 4.0.2.

I recently upgraded to Mac OS X Lion 10.7/11A511. I uninstalled the whole developer tools by using 'sudo /Developer/Library/uninstall-devtools –mode=all' and I installed Xcode 4.1/4B110 using the Mac App Store. I've been happily coding with my iPhone 3GS, but I won't longer work with the iPhone 3G.

When I connect the 3G, Xcode 4.1 asks for collection of the debug symbols. If I accept, it starts copying the files, but it gets stuck at roughly 80% of the process (see the attached screenshot #1 for the Organizer screen). If I look in the Activity Monitor I can see the DTDKSymbolHelper process eating up all the resources (see attached screenshot #2).

If I force kill DTDKSymbolHelper, Xcode will finish collecting the debug symbols and will believe that my 3G is ready for use. However, when I try to run my app on the 3G, the app copies successfully and it is run, but then the console shows several errors (see attached txt file), and the app gets stuck at the Default screen. The DTDKSymbolHelper process is spawned again, and it perpetually eats all the resources again.

If I exit the App via the home button and disconnect my iPhone 3G from the Mac, I can launch the app again and it runs perfectly, updated to the latest version.

If I connect my 3G to the Mac again, Xcode will ask again for collecting the debug symbols, and if I accept, it gets stuck at the same place.

I acknowledge that the most sensible thing would be to restore the phone in order to see if that fixes the problem, but I wanted to try and get to the bottom of the problem first.

In my Macbook Pro + iPhone 3GS this problem is 100 % reproducible, so please ask for any piece of information that you need.

Expected Results

Xcode 4.1 ether successfully finishes collecting device debug symbols, or it shows an appropriate error message.

Actual Results

Xcode 4.1 gets stuck indefinitely, with process DTDKSymbolHelper eating up all the system resources.

share|improve this question
    
Additional information: I tried on a different Mac with a fresh install of Xcode 4.1 on Lion, and the same result. It's definitively a problem with the phone, any workaround (apart restoring the phone) would be welcomed. –  rsanchezsaez Jul 27 '11 at 21:18
    
More info, this might be related to the problem shown in this question: stackoverflow.com/questions/4432886/… –  rsanchezsaez Jul 27 '11 at 21:33
    
I also tried with Xcode 3.2.6 and the problem persists. –  rsanchezsaez Jul 30 '11 at 3:42
    
In case anybody is still interested, this issue changed slightly with Xcode 4.2, and I posted an updated question here: - stackoverflow.com/questions/7922308/… –  rsanchezsaez Oct 27 '11 at 21:02
add comment

1 Answer

up vote 0 down vote accepted

In case anybody is still interested, this issue changed slightly with Xcode 4.2, and I posted an updated question here: http://stackoverflow.com/questions/7922308/xcode-4-2-error-0xc002-when-trying-to-use-a-jailbroken-iphone-3g-for-developmen

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.