Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've install Lion on both MBP17 2008 and iMac27 i7 2010. On the old MBP, Mission Control animation are smooth but on the iMac, the desktop slide away with a nice animation but then all the application window appear in a snap with no animation at all. Is there a way to turn this feature on again ?

share|improve this question
This isn't a feature, it's a bug. Have you tried restarting? – Nathan Greenstein Jul 26 '11 at 22:45
@Nathan : yes I did. Does not change anything – VdesmedT Jul 28 '11 at 11:41
possible duplicate of How can I disable animation when switching desktops in Lion? same slowness - same desire to disable the new animation – bmike Aug 9 '11 at 20:40
Is the OP trying to disable the animation, or make it work again? – Daniel Sep 27 '11 at 20:24
They're trying to make it work again. – Jason Salaz Sep 27 '11 at 21:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.