Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

You may be aware that Lion introduced MTMFS, the Mobile Time Machine File System.

I've had a couple of instances now where MTMFS has been chewing up an entire core of my dual-core (mid 2009) MacBook Pro for hours on end with no evidence that it's actually doing anything constructive.

As a consequence, CPU temperature rises and the cooling fans run fast and noisy.

Restarting the machine quietened things down again, but I'm expecting it to start again.

Does anyone understand MTMFS well enough to suggest why it's keeping itself busy (or is it most likely, simply a bug), or if there's currently any solution? I fear I may have gone deaf or been scalded to death before Apple release an update...

share|improve this question
Are you ok running a couple of terminal commands to see what's happening? – bmike Jul 30 '11 at 1:19

To track down the issue you may have to dive into fs_usage or other tools that capture filesystem activity as it happens.

Normally, I have seen minor corruption issues on a filesystem (or bugs in the code - it's hard to tell / hard to reproduce this issue). In practice I can't get it to fail again after cleaning the existing local backup.

  • sudo tmutil disablelocal
  • reboot the Mac in safe mode (which runs fsck and many other helpful and potentially irrelevant tests and checks for corruption)
  • reboot the mac normally
  • sudo tmutil enablelocal
share|improve this answer

I suffered this today when doing a find / -whatever -exec this-or-that {} \;

Suddenly mtmfs got 100% CPU. It turns out that mtmfs is a special filesystem mounted on /Volumes/MobileBackups. If you run something that will access files indiscrimately, such as a find (something many "cleaner" programs do) mtmfs will use a lot of CPU when its files are being accessed.

You have two options:

1) As suggested, disable local Time Machine backups (sudo tmutil disablelocal)

2) Make sure to exclude /Volumes/MobileBackups (or even /Volumes, as it can be a p.i.t.a. to run a find over network file systems) from the search command.

That should solve the issue.

share|improve this answer

Running sudo find / -type f -mmin -5 while mtmfs was using 85% of my Mac, revealed that the process was writing to /Volumes/MobileBackups/Backups.backupdb.

I guess that TM was doing its daily local backup.

share|improve this answer

I've noticed this as well on my new MacBook Air. I've found turning Time Machine off and on again will stop it chewing up CPU, but don't know how to stop it happening again.

share|improve this answer
The questioner was clear that a reboot may temporarily recover from the situation, but does not prevent the issue from arising again. – bmike Nov 7 '11 at 17:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.