Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since upgrading to Lion I notice that typing is automatically getting "corrected".

For example, I type "I posted to elance that" and the word elance automatically changes to "glance". I back up and change the 'g' to an 'e' and it changes it back to "glance" again.

I first noticed it in Mail, but I see it's also happening here in Safari too.

How do I turn this off? Note: I don't mind the 'red-squiggle' when it thinks there's a typo, but I don't want it automatically changing my text.

share|improve this question

3 Answers 3

Go to system preferences -> and then language/text

Hit the "Text" tab.

There is a checkbox that says "Correct spelling automatically". Uncheck it.

Look here for more info:

http://www.applegazette.com/mac/how-to-disable-auto-correct-in-os-x-lion/

share|improve this answer
    
Tried that and it didn't work because it looks like TextEdit and Safari have their own "correct spelling automatically" options that are enabled. Is there no way to change this globally? Also, I do like when it warns me of the bad typing with the red squiggle. It would be nice if I could have that without the annoying automatic changes. –  Robert Hume Jul 26 '11 at 17:35
    
For TextEdit go to the top bar and click TextEdit -> Preferences. At the bottom is a checkbox that says "Correct spelling automatically" uncheck that. For Safari I have no idea. Hope that helps! –  Chris Jul 26 '11 at 17:48
2  
For Safari (or any other app with a text input box, for the most part) right click (or control click) the text area, goto Spelling and Grammar, and deselect Correct Spelling Automatically. Screenshot –  Gauzy Jul 26 '11 at 19:44
    
Thanks Gauzy! That's the right answer. –  Robert Hume Jul 26 '11 at 21:26

Open a terminal window, and run this:

defaults write NSGlobalDomain NSAutomaticSpellingCorrectionEnabled -bool NO
share|improve this answer
    
Thanks, but I prefer not to fiddle at the command line. If it's not in a UI somewhere it scares me. :) –  Robert Hume Jul 26 '11 at 17:35
    
For both Chris and my solution, make sure you're completely closing and relaunching safari and textedit before testing. –  Curtis Tasker Jul 26 '11 at 18:12
    
The setting in System Preferences changes the same key in ~/Library/Preferences/.GlobalPreferences.plist. –  Lri Oct 7 '12 at 13:53
up vote 0 down vote accepted

User "Gauzy" posted this in a comment. I'm posting it here and marking it as the correct answer:

For Safari (or any other app with a text input box, for the most part) right click (or control click) the text area, goto Spelling and Grammar, and deselect Correct Spelling Automatically. Screenshot – Gauzy

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.