Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I can't get archive to work on Lion. When I choose archive in Mail.app it creates a folder called Archived. That's not what I want. When I choose delete it doesn't remove the message from my inbox. It is just greyed out. Right now I leave the messages in the inbox and archive them from my iPhone, which works great. Please help me get this working.

share|improve this question
add comment

2 Answers 2

If you're okay using Mail's delete function as archive, then simply go into Mail > Preferences > Accounts > Gmail > Mailbox Behaviors and deselect both of these options:

[ ] Move deleted messages to the Trash mailbox

[ ] Store deleted messages on the server

Screenshot:

Screenshot of settings

Then when you delete a message in Mail, you'll be archiving it.

Reference here:

https://mail.google.com/support/bin/answer.py?hl=en&answer=78892

share|improve this answer
add comment

I had the same problem, and it turned out that I had to enable Auto-expunge in gmail settings; otherwise actions performed in Mail don't sync up to the gmail server in a timely fashion. Just enable auto-expunge.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.