Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have updated from Snow Leopard to Lion with Safari Version 5.0.5. Now I can not update to Safari 5.1. There is no update in the Software Updater, and on the apple-download page, I only found a Safari 5.1 for Snow Leopard. When executing it, there is an error message, that it is for 10.6 only (see screenshot). Any idea how to get full screen browsing?

share|improve this question
2  
Lion ships with Safari 5.1. There's no need to update to it, you should already have it. To confirm click on Safari in the Menu and then "About Safari" –  mwidmann Jul 25 '11 at 20:25
    
Just to state the obvious, therefore not an answer: Safari 5.1 was one of the update packages issued recently via the Software Update. The idea at Apple probably was to up-to-date your Mac before installing the Lion... –  Tigran Khanzadyan Jul 25 '11 at 20:26
    
I have Safari 5.0.5 on Lion, so it seems not to ship with 5.1! I guess I did not update to 5.1 on Snow Leopard. Is there way to do it now? I've seen comments of people going back to Snow Leopard, update Safari to 5.1, then going to Lion. That seems to painful to me. –  daefu Jul 26 '11 at 8:25
add comment

1 Answer 1

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.