Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've just installed Safari on Windows XP SP3 and after succesful installation it starts and just hangs up. I also see process Webkit2Webprocess.exe which uses 100% of one core and nothing else happens.

Can you please give me some hints how to fix this?

share|improve this question
    
Seems like everyone's having the problem with the latest Safari upgrade... –  user8409 Jul 26 '11 at 16:36
    
can you perhaps let us know if this is still an issue? Did you resolve it? Can you add more details so an answer might be provided for others? –  bmike May 29 '12 at 14:37
    
There's a decent answer here and the OP could just uninstall Safari. Without more details, leaving this open for new answers doesn't seem to be warranted as it's not even clear what version of Safari is being installed at this late date. –  bmike Feb 27 at 18:34
add comment

closed as unclear what you're asking by Mark, Graham Miln, bmike Feb 27 at 18:32

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Safari hangs when it cannot find a network, like when you need to specify proxy settings. Try on a network that doesn't need a proxy; it will not hang there.

share|improve this answer
    
Can't reproduce this on the Macs here, is this a "behavior" specific to Windows? –  patrix Dec 2 '12 at 11:00
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.