Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After upgrading to Lion, I started experiencing this issue:

Internet stops working frequently.
- I open Safari and browse for some time - Suddenly I can't open any sites; Internet will stop working. - So I check WiFi; it is online and showing correctly in my MacBook Pro. - I check with my roommate and his Internet is working properly. - I switch to Google Chrome and it still doesn't work.

The solution is to turn WiFi off and back on, then restart my browser.

Does anyone else have this problem? Is this a bug?

share|improve this question
    
Does this happen right after you put your MacBook to sleep, or in the middle of using it? –  Nathan Greenstein Jul 23 '11 at 12:33
    
It sounds like you are not getting a DHCP renewal once your mac thinks your lease has expired. Have you tried running /System/Library/CoreServices/\ Diagnostics.app to narrow down the cause? –  bmike Jul 23 '11 at 13:45
    
Do the logs say anything? Check console.app –  Agos Jul 23 '11 at 16:03
add comment

2 Answers

up vote 5 down vote accepted

This is currently a known issue that lots of Lion users are reporting. The average seems to be 2 wifi dropouts per hour.

The current work around is (as you discovered) to toggle AirPort on/off.

This particular issue seems to be getting alot of attention so I'd expect a fix soon.

Apple support forum topic about this issue

share|improve this answer
add comment

This response describes a fix that worked for me:

Open up preferences and go to network. Make note of your settings as you will have to rebuild them.

Rename the preferences.plist to .old which can be found here: /Library/Preferences/SystemConfiguration/

Now go back to preferences and rebuild your settings as it will be blank. You may have to manually recreate a new location and then hit apply. This recreates a new preferences.plist

After this, I also had to reboot, and the problem went away.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.