Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After upgrading to Lion, all my 802.1X configurations are gone. There also does not seem to be a possibility to configure them via the system preferences:

802.1X

It just tells me to get a configuration file from my system administrator.

Question:

How can I create a profile manually like before, or, if this is not possible, can I create a configuration file myself with the data I have and how?

Update:

It turned out that it was sufficient to just provide my credentials at the when I connected to the network. I was just confused as there was not profile anymore in the preferences as you can see in the screenshot above. I hope the accepted answer will still be useful.

share|improve this question
    
Yep, that's how 802.1x works. You authenticate (usually but not necessarily "on the domain"), and you're provided a certificate to install. –  Dan Ray Jul 22 '11 at 13:57
    
Did you see a popup dialog for the certificate or is it properly signed? (Or do you know in this case?) –  Sable C. Jul 30 '11 at 7:26
add comment

1 Answer

up vote 2 down vote accepted

You need a .mobileconfig file that includes your 802.1X profile. Acording to apple ( http://support.apple.com/kb/HT4772 ) you can use the Server extensions of Lion to create it. Alternatively (and easier ) the Iphone Configuration Utility ( http://support.apple.com/kb/dl851 ) can also create it. If you upgrade to Lion from Snow leopard any existing profile is migrated.

share|improve this answer
    
It turned out that it was even easier. I could just type in my credentials at the prompt and it worked. Not sure if this is because I configured it previously. As you can see, in there are not configured settings in the above list. Anyway, creating a profile with the configuration utility is a neat tip. Thanks! –  Felix Jul 22 '11 at 11:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.