Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When using App Exposé on Lion ( Control- by default), the lower part of the screen above the dock is reserved for minimized windows. A new feature of at least TextEdit in Lion is that it also shows the most recent documents as icons, which makes for an absolutely crowded area. I never use MRUs in my workflow so that's an absolute waste of space and of time.

Is it possible to disable this behavior and only show minimized windows?

share|improve this question
    
Not just crowded, but confusing. It looks like I have ten documents open and minimized. Apple!! –  janaspage Oct 26 at 0:58

4 Answers 4

up vote 1 down vote accepted

OK, after twiddling different combinations, I found a solution that works (at least on Mac OS X 9.5 Mavericks).

1) Open the app in question (e.g. TextEdit).

2) Click Menubar / File / Open Recent / Clear Menu. Note that there is also a Menubar / Apple / Recent Items / Clear Menu. Clicking this general one doesn't help; click the app-specific one.

3) Open System Preferences / General and set Recent Items to None.

Note: While this keeps the minimized-items section of exposé clear of recent items, it also unfortunately disables access to recent items in most other places (e.g. the menubar or dock).

Boo Apple: http://www.apple.com/feedback/

screenshots

share|improve this answer
1  
Closest one yet. Also works on Yosemite. –  Lloeki Oct 27 at 8:38

Apparently setting the Number of recent items to None in general preferences does the trick.

General Preference Pane

Unfortunately it also disables the Open Recent submenu, but I honestly care less: having an uncluttered minimized windows list in Exposé is much more important.

share|improve this answer
1  
I've tested this answer and it doesn't seem to work for me. Even after setting the number of recent documents to none TextEdit behaves the same way. –  Samuel Mikel Bowles Sep 12 '11 at 13:54
    
I've noticed that behavior too if the MRU list was previously filled. I did this on a fresh install of Lion, so MRU list was not populated and it never filled up when None was set. –  Lloeki Sep 12 '11 at 20:48

I managed to figure out how to clear and permanently disable this in Expose so figured I'd post here.

I'm using BBEdit but imagine the steps are the same for TextEdit(?)

You have to set the Recent Items to 0 (as above) AND delete the contents of: /Users/[your username here]/Library/Preferences/com.barebones.bbedit.PreferenceData/

(As I say I imagine there's something similar for TextEdit)

This folder rather astonishingly contained the history of every file I have EVER edited in BBEdit(!!) some 4000 odd files - also a security risk in my book.

If you were very paranoid (as am I) you could also chmod this folder to be readable only so it is never written to:

sudo chmod -R 444 /Users/[your username here]/Library/Preferences/com.barebones.bbedit.PreferenceData/

Hope that helps... Apple/BBEdit should really include this functionality within Expose as an option so we can turn it off in my humble opinion.

share|improve this answer
    
I just tried this for TextEdit (com.apple.TextEdit.*.plist files), and it did not change the behavior. Running Mac OS X 9.5 Mavericks. –  janaspage Oct 26 at 1:09

I have just cleared recent items by going to apple menu, selecting "Recent Items" then "Clear Menu".

share|improve this answer
    
Did it also clear the recent items in App Exposé? It was not when Lion first rolled out. –  Lloeki Jul 16 '12 at 11:05
1  
I just tried and it did not clear Preview recent items, neither in the Dock menu nor in App Exposé. –  Lloeki Jul 16 '12 at 11:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.