Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have this strange situation in Mac OS X (10.6.8) wherein 2 accounts cannot be deleted nor can I reset their passwords.

If I try to reset their passwords I get "Reset Password Failed". I have tried booting with an install CD and using the Password Reset Utility - no joy.

If I try to delete the Account using the minus in Accounts, the Full Name disappears from the icon but the icon remains. If I exit Accounts and come back the Full Name is there again with the icon.

If I (sudo and) look at /Users only one of the accounts shows up.

Other things I have tried include doing the same above (password reset, delete account) as root rather than an Account with Admin privileges, Repairing the Disk (did find some problem with the volume but fixed it) and Repairing the Permissions.

Is the Netinfo database corrupted or something? How do I fix this?

share|improve this question
    
Did you try adding a new account see if that fixes it and allows you to delete the old ones? –  Martín Marconcini Jul 21 '11 at 13:00

1 Answer 1

up vote 3 down vote accepted

This is generally really easy to clean up.

The Snow Leopard user database for all accounts on the mac is stored as flat files in the directory /private/var/db/dslocal/nodes/Default/users

Just delete the offending userA.plist and userB.plist and the accounts will be "gone" after a reboot.

  • boot the mac in target mode and use another mac to delete the files
  • boot to single user mode (or get a root shell with sudo -s) if you are comfortable in a unix shell

There will of course be remnants of the user folders and their group membership potentially left lying around.

If you are concerned about that level of cleanliness - just boot back into a normal admin user and recreate a shell account using the same short name.

You can then correctly reset the password (retaining the home folder) or delete them cleanly and totally at that point.

Let me know if you still have a failure - it's super unlikely, but there could be a deeper problem if this doesn't work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.