Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After installing Lion, + doesn't go to the line start and + doesn't go to the line end.

Anyone know how to reconfigure this?

share|improve this question
1  
Hmm… this works for me on a MacBook Pro running Lion. Tried it in TextEdit and BBEdit. –  Nate Jul 21 '11 at 3:52
1  
Which programs is this happening in? It still works for me - though I do prefer using Control-A and Control-E respectively instead. –  Chealion Jul 21 '11 at 3:52
    
at the time I wrote this question it was not working anywhere. Now it's working everywhere, and I did nothing specific :S –  Victor Rodrigues Jul 21 '11 at 3:56
    
Same for me: it suddenly did not work some time after the Lion upgrade, and a few days later it worked again, without restart or logging off. –  Alexander Klimetschek Aug 18 '11 at 12:31
    
For me, home and end commands work only if I highlight the text with Shift key down. –  jelovirt Sep 6 '11 at 12:26
show 1 more comment

6 Answers 6

You could try restoring defaults by using the 'Restore Defaults' button in System Preferences shown below:

enter image description here

share|improve this answer
1  
Have the same issue. But this tip doesn't help. –  Ortwin Gentz Jul 26 '11 at 11:50
add comment

Removing ~/Library/Preferences/com.apple.universalaccess.plist.lock and logging out and back in did the trick for me.

share|improve this answer
add comment

This problem was driving me crazy.

Ortwin Gentz wrote:

Removing ~/Library/Preferences/com.apple.universalaccess.plist.lock and logging out and back in did the trick for me.

I didn't have a file with that name, but I had one with this very similar name: ~/Library/Preferences/com.apple.universalaccess.plist

I moved that file to the trash, then logged out and back in. Problem gone. Hooray!

Thank you, Mr. Gentz!

share|improve this answer
add comment

Coming from Windows I've had a tough time adjusting to the way home and end behaves. Luckily the guys at MacroMates had a blog post about this.

http://blog.macromates.com/2005/key-bindings-for-switchers/

Create a file at ~/Library/KeyBindings/DefaultKeyBinding.dict with the following contents:

{
    /* home */
    "\UF729"  = "moveToBeginningOfLine:";
    "$\UF729" = "moveToBeginningOfLineAndModifySelection:";

    /* end */
    "\UF72B"  = "moveToEndOfLine:";
    "$\UF72B" = "moveToEndOfLineAndModifySelection:";
}

I restarted and my keys were behaving as expected!

share|improve this answer
add comment

It seems to have something to do with the language you selected.

I had mine set to English - Canadian (eh :P)

setting Language & Text > Input Sources

uncheck English - Canadian check US

Once I did that my cmd + arrow key was back to normal.

share|improve this answer
add comment

Option + Command + right arrow (on the latest Lion update -- it changes)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.