Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I upgraded to Lion today, but was having the same problem on Snow Leopard. When I start up my Mac and login, it automatically connects to an NFS server. I know this because I see the server in Finder in the Shared section. I'm assuming I connected to the server at some point in the past, but I'm not sure how to make it stop connecting now. Where can I look? Even after ejecting the server, it reconnects on the next startup. What can I do to make it stop?

Further information - here's what my /etc/auto_home looks like:

#
# Automounter map for /home
#
+auto_home  # Use directory service
#
# Get /home records synthesized from user records
#
+/usr/libexec/od_user_homes

And running /usr/libexec/od_user_homes produced no output.

The mount doesn't show up in Disk Utility or the Directory Utility, and running lsof doesn't show the mount (/CIFS). df does show /CIFS and indicates that the Filesystem is x-browser:

Here's /etc/auto_master:

#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-          -static

And the output from mount:

/dev/disk0s2 on / (hfs, local, journaled)
devfs on /dev (devfs, local, nobrowse)
map -hosts on /net (autofs, nosuid, automounted, nobrowse)
map auto_home on /home (autofs, automounted, nobrowse)
x-browser: on /CIFS (nfs)
localhost:/gWMIVnK_1WG9ZzUq0q3qb7 on /Volumes/MobileBackups (mtmfs, nosuid, read-only, nobrowse)
share|improve this question
    
This is annoying. My cable modem(bthomehub3) shows up as a share. –  Stephen Aug 19 '11 at 15:43
add comment

9 Answers

up vote 5 down vote accepted

I had the same problem with CIFS-mount, x-browser… That happened because I tried Sharity 3 and 'deleted' it by putting the icon in the trash, like Mac users usually do. :) But the program was still installed and put the CIFS icon on the Desktop every day.

I solved it using the following Terminal command:

sudo /Library/StartupItems/Sharity3/uninstall
share|improve this answer
    
Yes! That solved it - thanks a ton! This has been bugging me for way way too long. –  Josh Brown Jan 16 '12 at 1:13
    
? The last comment made on Dec 16 to my answer provided an update that you may be running Sharity. I guess you didn't see it. –  AndrewNimmo Feb 27 '12 at 22:15
add comment

You may want to consider using the NFS Manager application to help you locate and disable the NFS automount. You should refer to this section of the manual for assistance.

The mount name /CIFS and the lack of NFS information indicates you may be running Sharity. Check if it's installed, using Spotlight. If it is, you can find the documentation here.

share|improve this answer
    
Thanks. The automounted drive didn't show up in there, though. –  Josh Brown Dec 15 '11 at 18:28
    
Ok. Can you open a terminal window, type: /usr/libexec/od_user_homes and hit return. Is something printed out on the following line? Next, in the same terminal window, type: cat /etc/auto_home and let us know what is printed out. –  AndrewNimmo Dec 15 '11 at 20:52
    
Thanks again - I updated the question to show the output of these. –  Josh Brown Dec 16 '11 at 14:47
    
Ok. What does cat /etc/auto_master return? Your question initially said NFS, yet a recent edit now also mentions CIFS. What does mount return in a terminal window? Finally, from the Finder what does ⌘I (get info) show for the mount type of the volume? –  AndrewNimmo Dec 16 '11 at 18:03
    
Updated my question with more info. Finder shows that the Kind on the CIFS folder is Sharepoint. I don't see anything in Finder about a mount type. –  Josh Brown Dec 16 '11 at 19:01
show 1 more comment

NFS mounts should show up in Disk Utility. Open Disk Utility.app (In /Applications/Utilities/) and under the File menu select NFS Mounts. Select the URL of the drive that keeps showing up and click the minus button on the lower left corner of the screen to remove it.

Disk Utility - NFS Mounts...

share|improve this answer
    
Unfortunately, it doesn't show up there. I'm currently chatting with Lyken and have discussed this: chat.stackexchange.com/rooms/883/… –  Josh Brown Jul 21 '11 at 4:47
add comment

Check your start up items in system preferences. It might be in there which would be why it keeps auto mounting.

share|improve this answer
    
I checked, and all I see are a few apps: iTunesHelper, Alfred, ClipMenu, DTerm, bzbmenu, Dropbox. I'd guess none of those are doing this, but maybe... –  Josh Brown Jul 21 '11 at 3:30
    
Was this machine in a managed environment? –  Lyken Jul 21 '11 at 3:33
    
Could you explain what you mean by that? –  Josh Brown Jul 21 '11 at 3:34
    
Were you logging onto a domain for this machine at any time? –  Lyken Jul 21 '11 at 3:35
1  
No, but I did log onto a domain with my previous machine and used Migration Assistant to migrate everything from that one to my new machine. So it's possible something got migrated. –  Josh Brown Jul 21 '11 at 3:38
show 2 more comments

save this as ~/Library/LaunchAgents/cifs.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>localhost.CIFS</string>
    <key>ProgramArguments</key>
    <array>
        <string>/sbin/umount</string>
        <string>/CIFS</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
</dict>
</plist>

(Translation: "whenever I login, unmount /CIFS")

I know it's not an answer, but since several reasonable attempts have been made to figure it out, I thought it might be time to suggest a "Well at least this way it won't keep annoying you" alternative.

share|improve this answer
add comment

Unless I'm completely misunderstanding your question... can't you just drag the server to the Eject button (trash can)?

share|improve this answer
    
Yeah, that works, but it's a pain to do that every single time I start up my computer... –  Josh Brown Jul 21 '11 at 3:28
add comment

Firstly, does lsof show which files are actually open on the share? Does df actually show a mounted filesystem or is Finder being helpful and pinging an available share and just connecting to see what the share points might be, not actually mounting a true filesystem.

Perhaps some program you are unaware is causing the mount.

There are lots of places you can cause a remote file system to mount - and we're all guessing them one by one (my guess comes in a moment). If you can pinpoint the exact files that are open - you might realize that's where the mount is happening and not have to disable automatic mounts (by disabling the launchd job com.apple.autofsd). One last tack to track down the cause of the mount might be to change the password (or require one) on the share temporarily and see what process throws an error on the mac.

Now to the guessing part ...

Automatic mounts can also be configured in the Users & Groups pane.

Do check that you haven't set up AutoMounts and several other settings that can cause file systems to be mounted automatically by looking over the Viewing pop up menu as well as perhaps just detaching from any directory servers that could push those mounts onto your mac as a matter of policy.

enter image description here

enter image description here

enter image description here

share|improve this answer
    
I ran lsof | grep CIFS (the name of the mount) and didn't get any output. df does show the /CIFS mount - the Filesystem is x-browser: I also checked Directory Utility and didn't find any mounts or Automounts. –  Josh Brown Dec 16 '11 at 14:55
add comment

Your mac is doing this because of cached MCX. It was at some point or it thinks it has or still is bound to a directory server, most probably Open Directory on OS X Server. I will bind it to whatever server you had bound to and do a clean unbind. also check on the server to see if you can see this computer account (you might have to enable the advanced view target icon tab, to be able to search via mac address etc and see hidden accounts)

share|improve this answer
    
So how do I resolve this on my Mac? I don't have access to the server. –  Josh Brown Dec 19 '11 at 16:06
add comment

I was having a similar problem, I was seeing three Sharepoint servers show up in the Shared section of my Finder window. I went to Users & Groups and disabled a Guest User account that was set up on my laptop. Once I deselected "Allow guests to log in to this computer" and "Allow guests to connect to shared folders" the problem went away.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.