Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So, I just downloaded and installed Lion on my iMac. However, I did so on a separate clean partition, and saved Snow Leopard on the other. So, in Lion, I tried to open iPhoto on my Snow Leopard partition, and it crashed. Here's the error message:

com.apple.iPhoto: dyld: Library not loaded: /Library/Frameworks/iLifeFaceRecognition.framework/Versions/A/iLifeFaceRecognition

Any help would be appreciated!

share|improve this question

4 Answers 4

up vote 0 down vote accepted

Though this is from 2010, I think that it will work:

You need to re-install iPhoto because it's missing parts of itself:

To re-install iPhoto

  1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)
  2. Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name. On 10.6 those receipts may be found in the Finder using the Go menu and selecting Go To Folder

In the resulting window type

/var/db/receipts/

  1. Re-install.

If you purchased an iLife Disk, then iPhoto is on it.

If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

Source: https://discussions.apple.com/thread/2658126?threadID=2658126

share|improve this answer
    
Thanks. I'll try that when I get a chance –  thekmc Jul 21 '11 at 2:32
    
Thanks! That worked! –  thekmc Jul 21 '11 at 13:35
    
No problem @thekmc. –  Odinulf Jul 21 '11 at 13:41

I had the same problem and I fixed it. It's really a iPhoto 9.1.5, Time Machine backup/restore and Lion upgrade issue.

To fix my problem I:

  1. Delete my iPhoto Library on my HD
  2. Restore the latest iPhoto Library from Time Machine
  3. Delete iPhoto software
  4. Reinstall iPhoto with my iLife 11 DVD
  5. Start iPhoto, but it asked me to upgrade from Internet. I did.
  6. With iPhoto 9.1, I started it and bingo, the issue is fixed.
  7. After a few tests, I did another software update to have the latest iPhoto version, 9.1.5

I tried many things the past two days, but only the steps described here worked.

Hope it will help you.

Serge

share|improve this answer

My iPhoto crashed as well. However, if I turned off photo stream in iCloud it loaded iPhoto OK. Not a final fix obviously but a temporary solution to get up and running.

share|improve this answer
1  
The original question was related to a quite specific setup issue (installation of Lion on a separate partition). I assume it's a different problem in your case. If you expect somebody to help you resolve it you should ask a new question. –  patrix Oct 23 '11 at 14:42

the 3ivx codec is causing crashes on iPhoto 11, 9.2 when Photostream is activated. Try remove it from

HD/ Library/ Application Support

share|improve this answer

protected by Community Oct 30 '11 at 3:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.