Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm on a Macbook Pro with a French Keyboard. Keyboard layout works fine when connecting to Windows XP Professional but I cannot get certain keys to work:

For example $, &, é, § and @ etc. work fine.

  • Forward slash / using + : works.

  • Backslash \ using + + : does not work.

  • Pipe | using + + L does not work.

Is there any configuration that I can do to make my keyboard work?

I've had this issue on my Windows VM in Virtual Box but fixed it with a custom keyboard layout. However when connecting to servers and workstations over the network this is not a solution since I can not configure each machine I need to connect to.

Under preferences, if I disable the Alt key it still does not work and on-top of that working without an Alt Key in Windows is no fun.

share|improve this question
    
Is the Windows system you're connecting to set to use a French keyboard? –  Joel Spolsky Jul 20 '11 at 23:19
    
Yes, windows places it to (FR) on login –  Derick Schoonbee Jul 20 '11 at 23:28
    
If I switch to EN I have to press shift-dollar to get a backslash. Would prefer a French layout :) –  Derick Schoonbee Jul 20 '11 at 23:30
    
Another test I tried that does also not work: Connecting from my XP VM via Remote Desktop. Strange that it does not work since in the VM my keys are mapped to work. –  Derick Schoonbee Jul 20 '11 at 23:35
    
I could get a backslash using Ctrl+Alt+8... The Windows on-screen keyboard is helpful for figuring out what's going on –  Joel Spolsky Jul 21 '11 at 0:09

3 Answers 3

up vote 1 down vote accepted

In the case of backslash \, the problem is a difference between where Macintosh French keyboards put the backslash (which is ++:), and where Windows French keyboards put the backslash (which is ctrl++8).

Since the way Remote Desktop works is that scancodes, not characters, are sent to the remote system, you have to honor the Windows keyboard and press ctrl++8 to get a backslash.

Pipe | is ctrl++6

I was able to debug this using the on-screen keyboards, which both Macintosh and Windows support.

share|improve this answer
    
Still does not work for me. Seems the right-alt scancode is ignored when sent from my Mac. The only way I could get it to work is to use the kebyboard layout editor to map pipe to Ctrl+Alt+Shift+L. It seems Mac Alt is always translated as plain Alt and Alt Gr is gone. –  Derick Schoonbee Jul 21 '11 at 9:14
    
I've reset my keyboard layout and it works now as the you suggested. But that's the "traditional" french layout. –  Derick Schoonbee Jul 21 '11 at 10:46

In windows symbols can be inserted by pressing Shift + relevant number key to insert symbol.

When using a macbook on Microsoft Remote Desktop connection, you are required to Hold down Cmd + Shift + Number Key.

This is the hidden option for inserting symbols into Windows machines over Microsoft Remote Desktop Connection.

share|improve this answer

I press left ctrl + right + right key on my mac to imitate AltGr when using remote desktop to a windows computer

I can type special characters and shortcuts that need the AltGr key on the remote PC.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.