Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a local apache running on my macbook pro and I need to run a SSL website on the local host. I have everything configured in Apache, but can't open port 443 on mac. I tried to add ipfw rule to allow 443 but it doesn't work.

share|improve this question

migrated from Jul 19 '11 at 22:29

This question came from our site for system and network administrators.

Have you simply disabled the firewall entirely and made sure the server is really listening on that port? I've been shocked how many times that's been my problem. – bmike Aug 19 '11 at 1:09

make sure 443 accessible from local and configured.

$ netstat -an|grep 443

allow 443 in ipfw

$ sudo ipfw add allow tcp from any to any 443
share|improve this answer
I did this, doesn't work. it shows me when I do ipfw list, but on nmap it doesn't show 443 – Stewie Jul 19 '11 at 14:59
@Stewie: Does it show up in the netstat output? If not, the firewall doesn't matter, because nothing is listening for connections on port 443. – Gordon Davisson Jul 20 '11 at 5:07
@Stewie nmap won't necessarily find all open ports, depending on how secure your system is. – rubixibuc Feb 16 '12 at 6:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.