Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried to connect a Nexus S to a MBP 2010 via USB. After connection, the Mac does not respond.

Anybody know why? I have tried it with a powered USB hub and get the same result: No responses for the USB storage.

share|improve this question
What do you mean by "not any responses"? Which response do you expect? – Loïc Wolff Jul 19 '11 at 9:35
What are you using from your Nexus-S? The USB Storage? The Internet Connection? – Martín Marconcini Jul 19 '11 at 11:00

Fire up system profiler on your mac. This can be refreshed to show all USB devices connected - even if there is a driver issue, at least you'll know if the cable and physical connection are good.

share|improve this answer

And finally I have found this issue is caused by a bad USB cable.

It is working when I use a HTC USB cable to connect to my MBP.

share|improve this answer

You may need to download software provided by Samsung to connect your device by USB.

share|improve this answer
The Samsung Nexus-S doesn't need any software and should appear as a regular USB storage where you can copy/move music, pictures and videos. – Martín Marconcini Jan 9 '12 at 10:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.