Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am having trouble with AFP Sharing a backup drive from one computer to another. Yesterday it was working fine and today it's not. I don't think any settings have changed since yesterday. When I try to connect via AFP in the Finder, I get this message

The server "192.168.1.6" may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

I have used ping on both computers to make sure the LAN is working, and it is. Any suggestions?

share|improve this question
    
Nothing comes to mind - reboot both and check firewalls are the only WAG I can think of.... (wild-assed-guess) –  bmike Jul 16 '11 at 22:55
    
Are you positive of the other computer's IP? If it's on a router it may have a new IP now. –  boehj Jul 16 '11 at 22:59
    
Yes. I have checked both computer's IP addresses in the "Network" pane of System Preferences. I also have rebooted both computers. Firewall...I have checked the router's firewall. What would I be looking for?? –  daviesgeek Jul 16 '11 at 23:38
1  
@daviesgeek I think @bmike meant for you to check Mac OS X's built-in personal firewall on both machines, to make sure your Mac OS X firewall isn't blocking your AFP connectivity. –  Spiff Jul 17 '11 at 4:47
    
@spiff is right in filling in my answer. Since ping works, basic connectivity is likely - the firewalls on both macs (under the security system preference) is the best bet to find something blocking traffic on ports different than the ping ports. –  bmike Jul 17 '11 at 11:03
show 1 more comment

2 Answers

Disable IPv6 and WiFi. Plug both in via Ethernet. Verify your targets IP. Turn AFP and all other sharing settings off on the target, and wait for it to disappear from the sidebar on the machine you're connecting from. Then re-enable AFP sharing on the target, and see it come back on the source.

Ping the IP, or even the name (foo.local if the computer's name is foo). Try connecting by clicking on it from the sidebar - failing that try using the Go menu (connect to server) and putting in a URL in the format afp://<name or IP here>.

Let us know how it goes.

EDIT: then, once that works properly, change one thing at a time. Enable WiFi on one machine and remove the ethernet cable. Then test. Then do the same on the other machin, and test. Then enable IPv6 on one.. test. Then the other. Etc, until you've worked your way back to how you want your machines to be set up. This can also help us isolate where the problem is happening (if you re-enable WiFi and sharing stops working...)

share|improve this answer
    
I will try this later. I don't have time right now, but I definitely will try. Thanks! –  daviesgeek Jul 17 '11 at 22:58
add comment
up vote 0 down vote accepted

I did figure out the problem; my router had MAC address filtering on. I turned it off, and ta-da! it's working now. Thanks to all who helped me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.