Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have some private SMS messages I want to hide. The problem is that they are displaying on main screen even when it's locked. So it was useless using password because it's displayed even with the lock.

How can I make SMS messages hidden on locked screen?

share|improve this question
add comment

4 Answers 4

up vote 13 down vote accepted

Go to Settings > Messages. There's an option "Show Preview" there. If you toggle this to off, it will stop showing SMS previews on the lock screen. This will also disable the alert popup when a new SMS arrives and the phone is not locked.

share|improve this answer
1  
This is outdated as of iOS 5.0 and above. See this for the updated version. –  Senseful Mar 24 '12 at 8:27
    
This is still relevant to iOS 5.0, if you want to get notifications of text messages on the lock screen but you don't want the content of the SMS to be visible. –  Jonathan. Mar 24 '12 at 9:20
add comment

If you're jailbroken, iBlacklist is an excellent app. You can block SMS and calls from your phone completely. The app intercepts them, and can save the logs. It is password-protected, so there's an extra layer of security as well.

Even if you don't want to blacklist anyone, you can still set it so that you don't get a popup at all when new SMS messages arrive. Your messages will go to your regular inbox, and you'll still hear the alert, but no popup.

Free trial, costs $12 to buy.

I have also heard about MCleaner. Never used that one though.

share|improve this answer
    
$12 for that. Seems a bit expensive for the features... –  Loïc Wolff Jul 26 '11 at 19:27
    
Yeah. I agree. There are alternative methods for obtaining said software too. Not that I condone or partake, but the pirates sail the jailbroken seas as well. –  Thomas Jul 27 '11 at 14:40
add comment

Go into settings->notifications->messages and turn off the badges option.

share|improve this answer
    
You can also turn off 'View in Lock Screen' to off from the same location. –  user17812 Jan 27 '12 at 3:38
add comment

As of the latest OS (5.0 and 5.1), you use the following method:

To turn off Message preview:

  1. Launch the Settings app.
  2. Navigate to Notifications > Messages.
  3. Scroll down to Show Preview and set it to Off.

Now, instead of showing the actual message on the lock screen and in notifications, it will only tell you that you received a message and by whom you received it.

share|improve this answer
add comment

protected by Community Jan 27 '12 at 7:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.