Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have the latest version of Remote Desktop Connection client form Mac (2.1.1), the one that is also included in Office 2011 but I am not able to connect to the Windows machine.

I checked the logs on the Windows machine and found nothing.

It keeps asking me for user/password/domain... and I am entering them properly.

FYI, the computer is on domain.

share|improve this question
    
Tried with CoRD and I got an interesting error "The trust relationship between this workstation and the primary domain failed." –  sorin Jul 14 '11 at 12:51

1 Answer 1

up vote 0 down vote accepted

Solved the problem by leaving the domain, joining it back and rebooting the machine (Windows).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.