Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I need Windows for my development environment on my Mac. I use Alt-U and Alt-S a lot in this software. I can't do this on my Mac. Is there a way to send the Alt key presses to the virtual machine?

Alt-U shows the Accessibility Utility Manager. Pressing Alt-S just types an "s". At work on Windows XP, neither of these behaviors happen.

share|improve this question
1  
I'm sorry, but I don't fully understand your question. Does the Alt key not work in Parallels? It works in the distributions I have seen... On a Mac, alt and option are one in the same for a key... –  Odinulf Jul 11 '11 at 15:27
    
I have updated the question. –  Mike Wills Jul 14 '11 at 3:36
add comment

6 Answers

up vote 1 down vote accepted

Disable the option for switching alt and cmd. The mapping should be: alt=option, cmd=windows.

share|improve this answer
    
Oh... I'll try that. –  Mike Wills Dec 1 '11 at 14:23
    
I'll have to remember slightly different keyboard mappings (from my Windows machine at work), but it seems to work. –  Mike Wills Dec 2 '11 at 2:54
add comment

I was able to get the desired effect by holding down the ctrl+alt keys, then releasing just the ctrl key to use the alt function.

Hurrah! No editing keyboard preferences required. Hope this helps someone else too.

share|improve this answer
add comment

For me the solution is to use the right Alt not the left Alt on the keyboard. For unknown reasons that does the trick.

share|improve this answer
add comment

You should be able to use the option key - I just used it on the Windows 8 Dev Preview as well as Windows 7 using VMWare Fusion 4. See picture below for detail of option key:

option key

share|improve this answer
    
It is these two particular keystrokes that don't work. I think the key strokes are being send to the OS first instead of the application like a dedicated Windows install may do it. (just guessing based on behavior). At this point I have basically given up and just swear every time I need to use the key combination. –  Mike Wills Sep 19 '11 at 13:48
    
Do you have VMware Tools installed on the VM? –  SoFLy Sep 20 '11 at 4:03
    
Yes. Recently I created a brand new VM (because of stupidity on my part ruining and old one). I have the same problem. My guess is listed above. –  Mike Wills Sep 20 '11 at 13:10
add comment

Can you use the "Optimize modifier keys for games" option; does it help you?

Problems with Ctrl, Alt, Cmd, Shift and other modifiers in games

(I want to use the option, but don't see it in my configuration panels...)

Oh, it's moved to the Advanced pane.

share|improve this answer
    
I have tried that and it doesn't work. It seems like Windows captures the event and doesn't pass it along to the active software. –  Mike Wills Nov 1 '11 at 13:15
add comment

Go in to preferences on Parallels and add mappings individually for each letter combo of alt and a letter. alta maps to alta, altb maps to altb etc for all key combos that involve alt. Time consuming but it appears to work so far.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.