Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a couple questions regarding this:

  • Is there a good source for old firmwares, including 3.2? (iClarified doesn't have 3.2)
  • Does Apple support downgrading for OS compatibility testing?

Thanks

share|improve this question

migrated from stackoverflow.com Jul 7 '11 at 2:01

This question came from our site for professional and enthusiast programmers.

    
Apple uses SHSH blobs to verify the restore/update, so if you do not have the SHSH blobs, you would not be able to restore. –  user6124 Jul 7 '11 at 2:26
    
@paiego In regards to "Does Apple not support downgrading for OS compatibility testing, if not then why?": We can't answer for why Apple doesn't support something. Since it's impossible to objectively answer that, I've removed the "if not when why" part from your question. Thanks for your cooperation. –  Nathan Greenstein Jul 7 '11 at 2:28
add comment

2 Answers 2

As bckbck already said, you need the SHSH blob from the earlier version. If you don't have it for the desired OS version, it's too late.

And iOS 3.2 was only supported on the iPad, so it won't run on iPod touches.

Should the data on http://theiphonewiki.com/wiki/index.php?title=SHSH be correct, then you can downgrade to iOS 4.1 with your device.

And you can get all firmwares at http://www.felixbruns.de/iPod/firmware/.

share|improve this answer
add comment

First, iPhonos (my way of saying “iPhone OS”) 3.2 was a unique version that was only available for iPad users. Since iOS 4, the iPad versions have the same version as the iPhone and touch version.

Second, on iPhone 3GS and touch 3g and later, plus all iPads, it uses a unique number, called a SHSH, which is a code made up of other codes in your device, including your device's firmware version and serial numbers of the hardware inside the device. But, the touch 1g and 2g, as well as the original iPhone and the iPhone 3G, do not have some of the hardware required for the SHSH to be generated, so they have to fill in some of the gaps in the SHSH that the missing hardware would have filled in. This needs to be done by the software, not hardware. iDevices that run iPhonos 3 or earlier don't know of this, so you can downgrade to any earlier iPhonos version without needing to save a SHSH.

You should use the firmware page that @jan.h mentioned, but make sure you use the second dropdown list, as the other dropdown is for iPods that don't run iOS.

Ad@m

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.