Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So at home ive been a linux user for a while, and frequently use byobu in the terminal. After a little searching I was unable to find anything like it for a mac, which I now have to use at work. I'm curious as to there being any software available to macs that can do this, or has a similar setup.

share|improve this question

2 Answers 2

up vote 8 down vote accepted

No need to look for an equivalent. It's available for the Mac. You can quickly and easily install it using the excellent Homebrew package manager. Once you have Homebrew installed, just type brew install byobu from the Terminal. It'll download the source, configure and install it.

share|improve this answer
    
I am not a user of github, but isn't it better to use the official application now that there is one? –  andersmoldin Jul 6 '11 at 2:20
    
I'm not sure what you mean. Are you asking if it would be better to install Homebrew using the Github application? –  michaelmichael Jul 6 '11 at 3:36
    
I was thinking of this: mac.github.com. But perhaps it does not do the same thing. –  andersmoldin Jul 8 '11 at 5:33
1  
Ah, I see what you're saying. No, it's not the same thing. The Github application is for managing Github code repositories. Homebrew is a package manager for installing and managing applications. –  michaelmichael Jul 8 '11 at 14:11
1  
I just did this but when I ran byobu it said "readlink: illegal option -- f" so I think i'm missing a dependency. coreutils and tmux are the dependencies I was missing. –  jrwren Mar 23 '12 at 0:41

Sorry to necro an old post, but I am adding my own tricks and hacks that were needed to get this to work, since this is the first result for "byobu on mac".

After performing brew install byobu, I encountered the same error that @jrwen encountered. I tried to install both coreutils and tmux, but it turned out that I had coreutils installed. However my $PATH was setup in such a way that /usr/local/bin came towards the end so the mac versions were always found first. I fixed this by adding

export PATH=/usr/local/bin:$PATH 

to my ~/.bashrc and sourcing it.

After this I still got an error saying

/usr/local/bin/byobu: line 53: ../Cellar/byobu/blah blah : No such file or directory

Not sure what brought this on, but the hack that I used to fix this was to add

cd /usr/local/bin 

To the top of my /usr/local/bin/byobu script

It now works!!!

share|improve this answer
    
Sorry for (again) necro an old, but what did you get F2, F3, ... keys to work when using Terminal.app? –  Mandx Sep 6 '13 at 14:42
    
@Mandx on my latest install it works out of the box. Do you need to hold down fn and press f2 or F3 to get them to work? That might be the default in mac and you can toggle it somewhere.. –  Karthik T Sep 7 '13 at 11:27
    
@Mandx I am currently using iTerm, but was earlier using it with TotalTerminal, which is built on top of Terminal.app –  Karthik T Sep 7 '13 at 11:27
    
Thanks for the response! I use the function keys as actual F#, I use them more that the "utility" keys. The issue was on the Keyboard section on the profile settings: Turns out I imported the Solarized settings from the Github repo and it had the keybindings wrong, for instance, the F2 key had this string \033[OQ and I noticed that a friend of mine (who uses TotalTerminal) had \033OQ instead. So I changed and it worked perfectly! Thanks anyway! –  Mandx Sep 7 '13 at 15:49
    
@Mandx ah ok, great that it is resolved! –  Karthik T Sep 8 '13 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.