Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

EDIT

This problem was solved in my case by changing terminal emulation from VT100 to xterm. Apparently the two programs I was trying don't behave properly when it comes to VT100 terminal line drawing. geekosaur's answer was accepted since it lead me to change what terminal emulation I was using.


Original Question

I noticed in certain terminal applications, specifically bpython and weechat, that certain characters are not being rendered properly in the terminal are not being rendered. I only just started using these terminal apps again recently after about 1.5 years or so ago back when I was on OSX 10.5 and I don't recall having this problem.

Here are some screenshot examples.

My weechat; notice the ? marks by the nicklist: enter image description here

What weechat is supposed to look like - a nice thin line separates the nicklist enter image description here:


My bpython - the border characters are replaced with q's and ?'s: enter image description here

What bpython is meant to look like: enter image description here


I've tried messing around with the encoding settings and various fonts, but nothing yet has solved this problem. I'd like to know what the cause of this problem is and how I might go about fixing it.

share|improve this question
    
I had the same problem with iPython. Setting it to xterm-color fixed it, so thanks! –  Agos Jul 1 '11 at 10:16

1 Answer 1

up vote 2 down vote accepted

Huh. Sure enough, it's not setting up VT100 line drawing by default, and apparently programs don't bother with little things like how you're supposed to send enacs before using smacs any more (no doubt because some Linux terminal emulator doesn't require it, therefore "nobody does").

Anyway, quick fix (here, at least) is to add to your ~/.bashrc

test -t && tput enacs
share|improve this answer
    
Actually - you just made me think of something I haven't tried yet and it "worked". My terminal emulation was set to VT100 and changing it to xterm "fixes" it for these two apps. I'll accept your answer since you informed me what the real problem is and gave me two workarounds (your addition to ~/.bashrc and leading me to check terminal emulation). –  whaley Jul 1 '11 at 3:18
    
That would make sense; the vt100 entry doesn't have enacs, the character sets are fixed. Terminal emulates xterm, which is an extended vt220 so it needs to be told what character set to use for G1. (See invisible-island.net/xterm/ctlseqs/ctlseqs.html for more details than you really want to know :) –  geekosaur Jul 1 '11 at 3:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.