Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have tried installing windows 7 on my MacMini.

I followed following steps.

  • Setup went perfectly But while installing I thought of not installing it.
  • So, I just restarted mac mini.
  • Pressed Alt key while booting
  • Started OSX
  • Launched Disk Utility
  • Removed windows partition.

But after doing all these stuff, I am facing new problem. Each time when macMini starts, I always have to press ALT while booting, otherwise it goes in indeterminate state.

Please guide me.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

When in the boot manager (the one when you press ⌥ Option on startup), click on the arrow (for the Mac OS X partition). The boot priority should then default to the Mac OS X one.

Otherwise, you can try going to the Startup Disk preference pane in System Preferences, and try setting it (by restarting).

share|improve this answer
add comment

According to discussions.apple.com you could also have removed the Windows partition with Boot Camp Assistant (located in /Applications/Utilities). It may be worth trying that just in case not everything was properly cleaned up during your attempts.

After that you can use go to your System Preferences, and select your OS X volume as the startup disk.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.