Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

How can I prevent iPhoto/Photos/Image Capture from launching everytime I plug in my iPad/iPhone?

share|improve this question

4 Answers 4

up vote 41 down vote accepted

Do this:

  1. Plug in your iPad/iPhone
  2. Open Image Capture
  3. Select your device ("devMikePad")
  4. Press the triangle in square symbol in the lower left corner.
  5. Select "No application" in the menu.

Here is a picture showing what to look for on Snow Leopard or Yosemite.

enter image description here

share|improve this answer
Interestingly this works also with Android devices (tested with Yosemite). – Calimo Feb 16 at 13:04

Preferences > General > "Connecting Camera Opens ..."
set it to "No Application"

added: How to do this with the new Photos app
Connect the iPad/iPhone
check or uncheck "Open Photos for this device"

share|improve this answer

For OS 10.10 and older, there is also a way disable this in bulk using terminal or a script:

defaults -currentHost write disableHotPlug -bool YES

This sets a flag to tell the system to not activate ImageCapture or Photos or iPhoto when a hot plug of an iOS device is detected. The benefit here is you pre-emotively disable the connection as opposed to reacting to each single device after an app has launched and the specific device is connected.

I've not had time to test this on 10.11 and the comments indicate that it's not working for everyone there.

share|improve this answer
Can anyone test this in El Capitan? I've run out of 'foreign' devices to test with. – Tetsujin Nov 4 at 11:36
This unfortunately no longer works as of 10.11 "El Capitan". – Nicholas H. Nov 5 at 13:44
@NicholasH. Hmm - I'll have to try this - I don't recall lots of pop ups on my 10.11 machines, but perhaps all those devices are individually black listed... – bmike Nov 5 at 13:55

On Yosemite, it was driving me nuts and the above answers helped some, but I still had to dig around a bit. Here's my own clarification:

Connect your phone and open Photos.

  1. Drop down the View menu and
  2. Select Show Sidebar (changing the option to Hide Sidebar as shown in my screenshot)
  3. Select your phone in the now visible sidebar and uncheck the box labeled "Open photos for this device"

I looked through all preferences, settings, and help menus I could find and found nothing. So thanks for the help!

Stop Mac from opening every time you plug in your phone!

share|improve this answer

protected by grgarside Oct 4 at 10:25

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.