Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The 'Personal hotspot' option is gone from my iPhone 4. Why? Is there any way to get it back?

share|improve this question
Still not showing :( – Metal Gear Jul 4 '11 at 13:28
Have you tried the suggestion I mentioned bellow? – Jannemans Aug 24 '11 at 9:11
Cellular Data Network is not showing in my iPhone – Metal Gear Aug 24 '11 at 11:33
When you go to Settings / General / Network, what options do you see? – Jannemans Aug 24 '11 at 13:08
Only these – Metal Gear Aug 24 '11 at 13:28

Make sure you have an APN + Username & password set under Settings > General > Network > Cellular Data Network. The bottom option "Internet Tethering" has to be filled in to enable Personal Hotspot.

Apple KB article - iOS: About cellular data network settings (viewing or editing the APN)

share|improve this answer
up vote 2 down vote accepted

Today I get the option back. After 6 month I found Onavo app was the reason to disable "personal Hotspot". I just uninstalled it.

I wrote an email to Onavo support about it and got this reply

Dave NOV 09, 2011 | 06:44PM IST Hi Jitendra,

Thanks for replying.

We're sorry to hear that, still trying to find a solution for this. Our team is working on several solutions, will update soon. Regards,

Onavo Support

share|improve this answer

Does your carrier require that you pay for this feature? I don't know how it's handled in India but in the US, the carriers charge extra for this. Of course, here in Canada, the carriers provide it for free provided your data plan isn't one of the minimal ones.

So perhaps the problem is that you are not entitled to use it by virtue of not having paid for it?

share|improve this answer
I was using hotspot from last 20 days it's just disappeared 2 days back – Metal Gear Jun 24 '11 at 16:10

The same had happened to me (Germany, O2). Last year, after I had used the Personal Hotspot (WiFi)once, it disappeared from the menu. Recently (new iOS, O2 officially supporting the iPhone by now), Personal Hotspot (the bluetooth thing, actually) worked for 2 minutes or so, then went dead. Technically it is still there but I woun't get anything through to the net.

I think it's something like this (not sure though): The first time you use the personal hotspot, your phone checks with your provider wether it allows to share you mobile internet connection to other devices. If not, it then disables it. If this is correct, the option should reappear when you purchase a 'shareable' data plan. May need some kind of reset though, aswell.

share|improve this answer
It was working fine for me some days ago – Metal Gear Jun 24 '11 at 16:03
I was using before without any problem – Metal Gear Jun 24 '11 at 16:10
Maybe your carrier just introduced the 'feature' of forbidding it only recently? – Heiko Haller Jun 24 '11 at 16:12
It might be but it should not :( – Metal Gear Jun 24 '11 at 17:26

Check Settings > General > Network, or restart the phone.

share|improve this answer
Tried as u suggested but problem is still there – Metal Gear Jun 24 '11 at 16:08

Ensure that your Data Roaming (located in Cellular under general settings) is turned on. Once you have done this, you will show your personal hotspot appear.

share|improve this answer

under cellualr data network, scroll down to internet tethering and write "www" in the APN section. Your personal hotspot will definitly work.

share|improve this answer

Settings, general, cellular, scroll down, personal hotspot, personal hotspot on. It will re-appear on the first screen. (Settings)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.