Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a co-worked whose name is Jennett. In Pages, I added her to my local dictionary (located at ~/Library/Spelling/LocalDictionary) by right-clicking on her name and choosing Learn Spelling.

However, OS X is not flagging Jennet with one "t" as being misspelled.

How can I make Jennet with one "t" be flagged as being misspelled?

I assume this problem stems from the fact that jennet—a female donkey—is found in the OS X dictionary. However, given that I don't write much about donkeys, let alone female donkeys, I'd prefer to be notified when I'm misspelling a co-workers name.

share|improve this question
add comment

1 Answer 1

up vote 8 down vote accepted

Removing words from the built-in dictionary is apparently more difficult than I thought it would be. Since your question is about how to prevent a particular misspelling of your co-worker's name, I have an alternate solution.

You can add "Jennet" to Mac OS X's text substitution list in System Preferences -> Language & Text -> Text

enter image description here

It will automatically correct the spelling for you each time you misspell it. You could add other variant misspellings for completeness, like "Jenet" or even make it auto-capitalize "jennett", but since most other misspelling variants don't have obscure English homonyms these will show up as misspellings.

share|improve this answer
    
Not a real answer, but a great workaround. –  zevlag Jun 23 '11 at 20:17
1  
I can no longer write about female donkeys, but now my co-worker's name will no longer be misspelled. Thanks. –  Matthew Rankin Jun 24 '11 at 14:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.