Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I added a calendar from my Google account in Ical and now it quit about 3 seconds after loading.

I have tried the solution described here:
but I don't even have user's Library > Application Support > iCal

OS X 10.6.7

share|improve this question
Just to clarify, are you literally trying to find a folder named user's library? – Ben Wyatt Jun 22 '11 at 1:14
XD no.. ~/Library/Application\ Support/iCal doesn't exist. – RyanScottLewis Jun 22 '11 at 1:17
I figured that was what you meant, but I just wanted to be sure. I actually don't have that folder either. It looks like that discussion was about Tiger, not Snow Leopard. – Ben Wyatt Jun 22 '11 at 1:22
I have also just tried to close iCal, moved /Library/Preferences/ and /Library/Preferences/ to the Desktop and still no luck. – RyanScottLewis Jun 22 '11 at 1:28
up vote 1 down vote accepted

You could try the same solution in the post you linked, but the calendars are stored in a different location (and format) in Snow Leopard. The calendars are stored as sub-folders of ~/Library/Calendars in Snow Leopard.

If you have multiple calendars, you can check the date each folder was created to see which one would be the Google calendar.

share|improve this answer
Luckily, I didn't have any data stored locally so I just removed all contents in that folder. Thanks! – RyanScottLewis Jun 22 '11 at 1:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.