Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPod touch running iOS 4.0 and an iPad running iOS 4.3.1, both jailbroken. They have lighttpd and PHP installed, however PHP seems to be an old version that I need to upgrade to use a WebSocket script.

How would I go about updating it? According to a phpinfo() call, it has been configured with parameters to do with iOS, would this matter?

Update 20/7/11 You can find my phpinfo at this tinypaste.

Thanks in advance for all of your help. Ad@m

share|improve this question
    
Can you give us your current output of phpinfo? Maybe pastie.org it. –  zevlag Jul 19 '11 at 20:52
    
@zevlag I've added the link to a tinypaste of my phpinfo in the question. Ad@m –  kirb Jul 20 '11 at 1:02
    
thekirbylover, i am a PHP developer. Just curious to ask why you install PHP on iPad and iPod? are you able to program on these devices? –  Kim Stacks Nov 25 '12 at 4:36
    
@kimsia, it's a great way to test code when I don't have a computer or access to the internet. –  kirb Nov 25 '12 at 8:37
    
@thekirbylover sounds like a good idea. what about webserver, mysql? –  Kim Stacks Nov 27 '12 at 5:12

1 Answer 1

up vote 1 down vote accepted
+50

If you build the iPhone toolchain in you local environment, you can compile PHP locally and then move it to iOS.

http://stackoverflow.com/questions/4001510/compile-php-with-gd-for-iphone-os-4-1

http://george.insideiphone.com/index.php/iphone-toolchain/

http://code.google.com/p/iphone-dev/

http://www.sj99.com/toolchain.html

I've not done this, but I'm curious, and will make an attempt myself over the next few days, and update this answer as I go along.

share|improve this answer
    
Thanks for the answer, I will try this method tonight and I will tell you how I go. Ad@m –  kirb Jul 20 '11 at 1:05
    
Ok... I tried it on my device and when I run ./configure from the folder I extracted php's source code to, I get a message saying it couldn't find gcc. On installing from Cydia, I am told libgcc wasn't found. I haven't tried installing a toolchain yet, but I will try that now. Ad@m –  kirb Jul 20 '11 at 12:33
    
I still haven't tried installing the keychain, but the bounty ends tomorrow so I will give it to you. Thanks for all your help for my question. Ad@m –  kirb Jul 25 '11 at 8:36
    
Thanks Adam, I've not tried it yet either. I'll hopefully get time some evening this week. –  zevlag Jul 26 '11 at 13:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.