Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

For the most part iCal and Google Calendars via CalDAV just work for me. But irregularly, throughout the day, iCal will start bouncing in my dock and display a warning like the following:

iCal Sync Error

What I know about the problem:

  • It happens randomly. I can hit Refresh All in iCal and this sync error won't occur.
  • The account with the error can change. It's not always a problem with the same account. I keep three Google calendars in sync with on iCal instance.
  • It happens randomly throughout the course of a day. I can't predict when a sync will fail with this error.
  • It does happen at all hours. I've had the pop-up show up at 9 am, and 9 pm and even 3 am.
  • I've been unable to tell if the error results in an out-of-sync state between iCal and Google Calendar. That's what makes me nervous.

How can I make these sync errors go away for good?

share|improve this question
4  
This pops up for me once every few days. Generally it happens when my internet cuts out for a second while iCal is trying to do a refresh. I've never found it to be harmful. My advice is just to ignore it. –  Harv Jun 16 '11 at 20:03
    
@Harv: thanks. The frequency is definitely higher for me. More like 5-10 times a day. It does get annoying. Since Internet is stable when it happens as remote ssh sessions and what not aren't severed. –  Ian C. Jun 16 '11 at 21:15
1  
I use BusyCal, which syncs to Google Calendar. I've never seen this problem. –  Daryl Spitzer Jun 16 '11 at 22:45
    
@Daryl I'm not ready to give up Fantastical which, right now, only works with iCal as a bridge to my Google calendars. –  Ian C. Jun 17 '11 at 0:19
1  
@boehj I don't use Mail.app but iCal was opening it on occasion when I had a "send email" notification set in a calendar entry. I had to purge email notifications from my Google Calendar entries to stop both Google and iCal from sending email alerts to me. –  Ian C. Jun 17 '11 at 2:09
show 4 more comments

4 Answers

up vote 2 down vote accepted

This is a common error. The iCal auto setup has created an incorrect address for you. There should be no "slash" / at the end of the address i.e. it should be

/calendar/dav/youremail@domain.com/user

To fix it, go to Preferences / Accounts and change the address, removing the final / from the Server Path setting.

AFAIK Lion no longer has this bug.

share|improve this answer
    
I've made the changes. Lets see how it plays out over the next few days. Thanks! –  Ian C. Jul 26 '11 at 18:47
    
2 days without a pop error. That's a new record. @dan8394 has nailed the solution. Thanks! –  Ian C. Jul 29 '11 at 0:59
add comment

On visiting the URL mentioned with my email address, I get:

Method Not Allowed

Error 405

So maybe Google changed something on their servers which prevented iCal from syncing. Try looking through Google's blog to see if any changes have been made, and how to fix it.

Ad@m

share|improve this answer
    
From Google's docs on how to set up a CalDAV-based link to your calendars in iCal: google.com/support/calendar/bin/answer.py?answer=99358#ical -- that's the URL they give you to connect iCal to your Google calendar. Also note: failures aren't reproducible. One refresh it will fail, the next it will not. –  Ian C. Jun 20 '11 at 1:33
add comment

A similar error tends to happen to me when I have recently switched wireless networks or my computer first comes out of sleep and I have iCal already loaded, but it hasn't reconnected to the wireless network.

Have you noticed any correlation to your internet connectivity and the issue?

So far, I haven't noticed any sync errors and I just hit OK.

In the iCal prefs under Accounts, what do you have with your Refresh calendars interval? Have you tried messing around with that? Perhaps changing it to every 30 minutes or every hour might help.

share|improve this answer
add comment

I've had this experience myself and have been using iCal with Google Calendar for several months now. Perhaps you are adding events too quickly. I found that these steps helped in resolving my issues:

Firstly, I'd suggest backing up all of your calendars. To do this just log into the Google Calendar site with your username and password. Once logged in, access the settings tab in the left column and go to the 'calendars' pane. Once you're there, there should be an "Export Calendars" link somewhere on that page. Click on this link.

Your calendars should all appear in a folder within the Downloads folder automatically (if using Safari). Once you definitely know that this is complete, remove all of your calendars on the Google Calendar settings page (DON'T UNSUBSCRIBE!). Once they are gone, then re-import them to the online Google Calendar Settings page using the "Import Calendars" link.

You will most likely have to set up iCal again, particularly if you have multiple calendars which appear as delegates.

share|improve this answer
    
Unfortunately I can't delete all the calendar content because some of them are shared among co-workers. –  Ian C. Jul 18 '11 at 14:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.