Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been having this problem for some time now - first I thought it was some temporary thing with CNET servers, but it doesn't seem so.

I can see the index pages of CNET sites (download.cnet.com, news.cnet.com), but when I delve deeper by clicking some application link on download.cnet.com or get direct link to some news from Twitter, I get error 'page not found' as seen on the image:

enter image description here

It seems that all links that point to CNET URLs having .html in them yield errors constantly. Other pages (e.g Mac software etc) are mostly OK (at least for the first click, but repeatedly refreshing gets me few random errors too)

This happens with all my browsers (Safari, Chrome, Firefox, Opera), whereas it does not happen with IE 8 running on Win 7 inside a VirtualBox on the same Mac, so it is not related to my network, but with my Mac borwsers somehow or Mac OS X.

BTW, all other websites are totally OK and this is only related to *.cnet.com sites. I have extensions and add-ons in Safari, Chrome and Firefox, but Opera is vanilla as I only use it for testing purposes, so could not be caused by some extension.

Specs:

  • Mac OS X 10.6.7
  • MacBook Pro 6,2
  • Safari 5.0.5
  • Chrome 11.0
  • Firefox 4.0.1
  • Opera 11.10
share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

Possible solution: changing first preferred language in browser.

It might fix the problem if you choose English as you first preferred language in browser settings. When requesting a page, browsers sends list of preferred languages for content. (For example, based on these settings Google redirects you to your local Google site.)

Changing preferred language:

  • Firefox 5: Tools->Options->Content->Languages.
  • Chrome: wrench-icon->Options->Under the Hood->Web Content->Languages and spell-checker settings (instructions)

It might be working on your virtual machine if default Windows (in VM) language was set to English. Then browsers would also choose English as your default content language.


When my default language was set to English or German I had no problems navigating cnet sites. After setting my first preferred language to Lithuanian I was getting same errors as you.

It appears that this is internal cnet bug.

Tested on Windows XP Firefox 5, Chrome.

share|improve this answer
    
Testing with Crome it worked. Thank you. I don't visit CNET that often, but now at least I know how to access it when I really need some article. Thanks. –  Laas Jul 4 '11 at 15:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.