Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

For every torrent I download, I set its destination to my fileserver, which my Mac is connected to via Samba. When download speeds are higher than about 3 megabytes a second, Transmission will lock up (beach ball) for 10-15 seconds, work for about 10-15 seconds and then repeat.

Moving the data files to the local OS X drive completely eliminates this behavior, even at speeds above 5 MB/s. Finder doesn't seem to have any problem writing to the share at speeds even higher than that.

I posted on the Transmission forums that, when saving to the Samba share, I would constantly see "Prefetch failed, Operation not supported" debug messages in the Transmission log; literally hundreds of them every second for every torrent being downloaded. I suspect this has at least something to do with it, but haven't gotten a response on their forums.

Other than "Just save stuff on your local disk then, dummy", is there anything I should try?

share|improve this question
    
I ENVY you getting those download speeds! Who is your bandwidth provider? Sorry, I have no idea about solving your problem. I would try another torrent downloader, uTorrent for example. That would confirm if the problem does indeed lie with Transmission, or not. –  Stefan Youngs May 25 '11 at 22:09
    
Verizon FiOS, 35/35. –  Robert Speicher May 25 '11 at 22:32
add comment

2 Answers 2

Just to make sure of a couple of things. When you say "which my Mac is connected to via Samba" do you mean that your file server is a Unix/Linux box running Samba or do you mean that your Mac is connecting to a Windows server using SMB?

The Mac since OS X 10.7 has not used Samba as either server or client but replaced it with an Apple implementation of SMB. So unless you are using 10.6 or earlier then you are not connected using Samba on the Mac.

Back to your problem. Almost certainly the problem is on the server side, I would have a careful look at the server software logs and perhaps turn the log level up for a couple of hours while you run some tests. If you are running Samba then I'd carefully tune it to see if you can configure your way out of the problem.

share|improve this answer
add comment
  1. Download latest version of Transmission
  2. Still having trouble, then limit the DL speed to 2.8MB/sec

I find that when I use Transmission at speeds less than 3.0MB/sec, I tend to not have the problems with a SAMBA share that you are having.

It writes to the disk in a different manner than what a direct connection does. Torrents create an empty file(s) that represent the downloadable content. Then they write to this file. Direct connection sends a request for the allocated space to the share/server and sees if it is available. If yes, it proceeds to start filling in the gap with the data until the transmission is complete and the end of file is written to the file system.

If you want an alternative option, create the download, add it to Transmission, but pause the download for a few minutes - THEN start the download as per normal. That way it should have enough time to write the inflated empty file first, and then start writing the data into it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.