Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Safari, the default PDF-Viewer in Safari is "Preview".

Unfortunately, since I installed the Acrobat Reader, this default changed to the Acrobat Reader, which is extremely annoying.

How can I change this back to "Preview"?

share|improve this question

5 Answers 5

up vote 26 down vote accepted

Go to the "Help" menu in Safari and select "Installed Plug-ins". This will open a new tab displaying information about all of the currently installed plug-ins. Find the entry for Adobe Acrobat. Below it will be a line that reads something like:

Adobe® Acrobat® Plug-in for Web Browsers — from file “AdobePDFViewer.plugin”.

Note the name of the file from that line.

On your hard drive you will find a Library folder. In that folder will be another folder called Internet Plug-Ins. Inside that folder you should find the file that was shown in the "Installed Plug-ins" tab. The full path should be /Library/Internet Plug-Ins/AdobePDFViewer.plugin. That file needs to be deleted. Dragging it to the trash will do the trick.

If you are not sure you want to delete the file, you can move it to another location. For instance, you could create a new folder named "Disabled Plug-Ins" in the "Installed Plug-Ins" folder, and move the file to the new folder.

Then quit & relaunch Safari.

Adobe acknowledges this is a "known issue" and recommends this procedure.

share|improve this answer
1  
Here's another way to get to the location of the plugin: Copy that plugin name (such as AdobePDFViewer.plugin), open Spotlight by clicking the magnifying glass icon in the menu bar, paste the plugin name, then use your mouse or arrow keys to highlight the result that matches the name and press ⌘-Enter to open a new Finder window with the file selected! –  smileyborg Jan 3 at 0:25
    
In Safari 6.1.3, it does not appear that restarting the browser is needed. New PDFs simply start using Preview. –  Ryan Marcus Jun 9 at 14:56

A thread on macworld covers this. Should work by either by removing the plugin from the internet plugins folder or by changing the settings in the Adobe Reader preferences. The plugin is pretty annoying, I never installed the Adobe Reader again.

share|improve this answer
    
Changing the preference in the Acrobat viewer app (either Reader or Acrobat) is probably better; I have a feeling that if you remove the plugin, then Acrobat will think that it's install is "damaged" and may pester you to "repair" it. This might not seem like an issue, but intentionally creating a false positive doesn't help you detect when the installation is damaged for some other reason. –  Viktor Haag May 25 '11 at 12:59
2  
Unfortunately the "Display pdf in browser using..." was not uncheckable (grayed out). Adobe Reader is an incredible trashy application on the mac! –  daefu May 30 '11 at 6:56
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  daviesgeek Apr 26 '12 at 16:33

The following solution below works well (for me) but misses a few steps. Here is what I did:

  1. Quit Safari
  2. Find both the AdobePDFViewerNPAPI.plugin and the AdobePDFViewer.plugin files in "Library/Internet Plug-Ins"
  3. Copy both files to your desktop (you might be prompted for the admin password) -- leave this folder open as well
  4. Right-click on one of the files (doesn't matter which one you do first) and select "Show Contents"
  5. Make the edit as per below to the Info.plist file
  6. Repeat steps 3 & 4 for the other file
  7. Copy both of the .plugin files back to the original folder (you might be prompted for the admin password)
  8. Start Safari

Original content is below:

The other answers completely remove acrobat reader. While I dislike acrobat reader, it is simply the only choice when there are PDFs with acrobat forms which preview is not great at handling. So a better approach could be to retain the plugin for the PDFs with forms (which has a separate mime type) and open our simple PDFs with preview.

To do this, open the file: /Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin/Contents/Info.plist and remove the following block of code:

    <key>application/pdf</key>
    <dict>
        <key>WebPluginExtensions</key>
        <array>
            <string>pdf</string>
        </array>
        <key>WebPluginTypeDescription</key>
        <string>Acrobat Portable Document Format</string>
    </dict>

Removing this will un-register acrobat reader plugin from being utilized for simple PDFs while Acrobat reader will continue to open the PDFs with other form data.

share|improve this answer

The solution is found on Adobe's help site:

Place AdobePDFViewer.plugin and AdobePDFViewerNPAPI.plugin in a new folder.

share|improve this answer

the best solution is just to put Acrobat Reader in the trashcan. It's 400 Mb of recovered space on my HD

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.