Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently at a hotel that forces you to click through an "accept screen" before being able to access the Internet.

The way it works, as best as I am able to tell, is;

When you make your first port 80 HTTP request after joining the wifi network, thenproxy server intercepts your request, and takes you to a screen in which you must read the terms of service, check a box, and click the submit/accept button.

The problem is that it does this only for first request, then denies all additional port 80 requests, and disallows all other requests until then page is acknowledged.

The issue at hand is that this page only appears for the first HTTP request, and with the myriad od sparkle-update powered software I have running, I'm suspecting that the confirmation screen is being delivered to one of these apps, instead of too my browser.

I've tried logging in with holding shift after entering my password (disables login items) which disabled everything except for MenuMeters, and still I could not get the foxy confirmation screen to come up.

I rebooted into safe boot mode and was able to get the confirmation screen to come up. So I rebooted normally. Unfortunately, I could not access the internet after doing so, and I suspect the confirmation screen once again became trapped behind a menu bar app.

Is there some step I'm missing that may drastically reduce the difficulty I'm having with this confirmation step?

share|improve this question
up vote 2 down vote accepted

What about an application level firewall like noobproof(free) or little snitch(paid) to block any requests and then only authorize your web browser?

share|improve this answer
That's a pretty good idea. I do have little snitch already, it's just been in log (no prompt) mode for some time. I'll give that a shot. – Jason Salaz May 22 '11 at 19:02
noobproof link is broken – user6124 Jun 11 '11 at 7:20
fixed the broken link. – ConstantineK Jun 11 '11 at 22:59

Had a similar issue at a DoubleTree a few weeks ago. Switching to Safari to surf to the first page fixed the problem. Guess there was something in Chrome that just didn't want me to use hotel WiFi.

share|improve this answer
At the height of my frustration, I had chrome, safari, and firefox attempting to reach google. All of them eventually timed out. – Jason Salaz May 22 '11 at 19:02
That sucks man. – Ian C. May 22 '11 at 19:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.