Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have noticed some strange behavior when using an external monitor with my MacBook and DejaVu Sans Mono (or Panic Sans) with Terminal.app and TextMate.

If I launch these programs prior to plugging in an external monitor, when I plug in the monitor, the fonts appear like so.

However, if I plug in the monitor first, and then open the application, the fonts are displayed like this.

Is there some way to ensure that the bolder, clearer version is always displayed, regardless of when I plug in an external monitor?

Note: I have noticed this behavior on many different monitors, connected via both DVI and VGA.

Thank you.

~Arun

share|improve this question
    
I ran into a similar problem with Xcode. Unfortunately, it stuck even after disconnecting the monitor and I had to reinstall Xcode. See stackoverflow.com/questions/6079590/… –  TechZen May 22 '11 at 17:31
add comment

1 Answer 1

up vote 3 down vote accepted

The problem has to do with LCD font smoothing.

This Mac OS X Hints tip describes how to fix the problem:

In Snow Leopard, you can only choose between Automatic and Standard CRT. Since few people use CRTs these days, most users now have only one option: Automatic. The problem with the Automatic option is that OS X incorrectly detects many third party LCD monitors as CRTs, and consequently, disables LCD font smoothing.

You can force OS X to use LCD font smoothing on all displays with this Terminal command:

defaults -currentHost write -globalDomain AppleFontSmoothing -int 2

The number 2 here corresponds to Medium - Best for Flat Panel. You may also use 1 for light smoothing, and 3 for strong smoothing, as per the original OS X font smoothing options.

You might have to re-login (maybe even restart) for this to take effect.

share|improve this answer
1  
No need to restart; you just need to relaunch the apps in question. –  NSGod May 22 '11 at 11:57
    
Thanks so much! –  Arun Seehra May 23 '11 at 4:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.