Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My Macbook Pro 15" (Early 2011 - the one with Thunderbolt port) constantly kernel panics whenever Cisco AnyConnect establishes connection.

The panic tends to happen in the first ~30 seconds after connection is established.

The crash log is available here: https://gist.github.com/d947e73b0b6c17a863b7

Any thoughts?

Some details: Macbook Pro 15" i7 Early 2011 (the one with Thunderbolt) Cisco AnyConnect version 2.5.2019

PS. I asked this question on the Apple Support forum, but so far I have got no answer :(

EDIT: This problem originally occurs in Snow Leopard, but problem persists in Lion (10.7), even after a fresh install (not upgrade from 10.6)

share|improve this question
    
Do you have to use the Cisco client? While I haven't used the AnyConnect client, I did use the Cisco VPN Client and had kernel panics with it. I switched to using the built-in VPN client over a year ago and haven't had a kernel panic since then. –  barryj May 21 '11 at 6:23
    
@barryj: AnyConnect is using SSLVPN while the built-in VPN support only works over IPSec. I don't think I can use the built-in VPN, sadly :( –  ryanprayogo Jul 27 '11 at 4:18
    
Cisco now has at least version 3.0.5080 of AnyConnect -- any chance you can upgrade your AnyConnect client? –  Lars Rohrbach May 20 '12 at 7:55
add comment

2 Answers

I found a solution for this issue, and wrote about it here :

http://technie.net/kernel-panic-on-macbooks-20102011-with-cisco-anyconnect/

There's a bug in Cisco AnyConnect, but following the guide on the link, it will be able to work.

share|improve this answer
    
Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. –  patrix Nov 25 '13 at 13:32
add comment

I've experienced the same issue on an iMac running OSX Lion (10.7.3). I submitted a bug report to Apple and tweeted at @anyconnect. You will need to work with Cisco support or use another version of the app unless we can narrow down the specific setting that is causing this crash.

share|improve this answer
    
Was there any resolution and information on version of AnyConnect that causes this? –  W Cerniuk Feb 12 '13 at 13:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.