Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Having problems with an iMac that I bought today. It's a 21", 2ghz Dual Core with 4GB ram. I'm connecting to my router via ethernet, and I can load up my remote websites and servers using the ip address, but when using a domain, safari complains with "You are not connected to the internet"

It's a fresh install of snow leopard 10.6.3 - I've tried running the Network Diagnostics and it just keeps saying it can't resolve the problem.

Would appreciate any ideas.


share|improve this question
Can you tell us what you have in System Preferences -> Network -> Ethernet -> DNS Server? (you can try the OpenDNS there: ( (it's free). Or Google's own DNS: –  Martín Marconcini May 20 '11 at 20:12
I tried adding google's DNS servers at and - But upon clicking Apply, everything got set back to the automatic configuration. –  Dave May 20 '11 at 20:30
could you post a sshot of your network settings please? –  Martín Marconcini May 20 '11 at 20:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.