Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a linksys router which runs "tomato" Linux and serves as the local DNS server. It runs dnsmasq.

I recently upgraded from OS X 10.4 to 10.6. Since then, resolution of hostnames on my local network works in some cases but not others. Previously, this all worked as expected.

Here's an example:

tesla:~ cell$ ping watt
ping: cannot resolve watt: Unknown host

tesla:~ cell$ ping watt.local
ping: cannot resolve watt.local: Unknown host

tesla:~ cell$ ping -c1
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=0.659 ms

--- ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.659/0.659/0.659/0.000 ms

tesla:~ cell$ host watt.local
watt.local has address

tesla:~ cell$ host watt
watt.local has address

My guess is that the host command is querying the DNS server directly, whereas ping and any GUI apps (ie. Safari) are using some sort of Mac DNS resolution routines, which are not working properly.

Please let me know if there's any other info I should provide.

Edit: included pinging ip directly in above example

Edit 2: My domain is using .local

share|improve this question
ZOMG!!! "By default, any hostname ending in .local is treated as a Bonjour host rather than by querying the DNS server entries in Network preferences." ARGH!!! why couldn't they have picked something like ".bonjour"? see – Jason Pepas Sep 12 '10 at 1:55
ugh, you can't simply disable bonjour because of… – Jason Pepas Sep 12 '10 at 2:08
does pinging the IP directly work? – Kyle Cronin Sep 12 '10 at 2:12
indeed, changing your domain name appears to be the path of least resistance. I'm surprised -- apple typically makes very smart decisions in how they choose to implement things. this is the first implementation decision I've come across which I'd really consider to be quite a boner. I mean seriously, picking ANYTHING other than ".local" to special-case for bonjour would have been better. – Jason Pepas Sep 12 '10 at 2:12
@Kyle yes, it does. I should have thought to mention that. I'll update the question. – Jason Pepas Sep 12 '10 at 2:14

If you're serving .local via unicast DNS (instead of multicast DNS, as specified in this draft internet standard), include an SOA record for .local; as of v10.6, OS X detects this and switches .local resolution to unicast DNS. Earlier versions of OS X have other methods of forcing unicast resolution - see Apple's KB article #HT3473 for details.

share|improve this answer

solution: don't use '.local' as your domain name. lame.

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

This is really a comment, not an answer to the question. You can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – CajunLuke Aug 20 '12 at 22:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.