Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Macbook Air (Late 2010) and am running Windows 7 Home Premium via VMWare Fusion. It works great, except that I have to press the key labelled as '@' (i.e. shift 2) to get a quote mark ", and vice versa - press the quote key to get an @.

How can I configure Windows to know that I am using a Mac keyboard? It detects the keyboard currently as a standard PS/2 keyboard. I live in the UK so the keyboard might be set up for UK as well.

share|improve this question
    
Which version of Mac OS X are you using? Which version of VMware Fusion are you using? Have you correctly installed the newest version of VMware Tools for Windows 7? –  Wheat Williams Oct 8 '11 at 14:48
    
Thanks for the info about the Keyboard Layout Creator. I now have a working install for the UK based on my MacBook Air purchased in the US. The grave and tilde key works correctly, and I have pound signs, hashes and euro signs just where I would expect them. And the speech marks and at sign work too! This has been driving me slowly nuts for weeks, so thanks again for the info. If anyone want the file then email me at rpjcheney@gmail.com. Cheers - Rich –  user23981 Jun 14 '12 at 12:38
add comment

5 Answers 5

You are using a US keyboard layout. Switch it to UK.

share|improve this answer
add comment

Changing to UK keyboard did not help in my case as it was already the default, so I found this page with a zip file you can download as well as good clear examples. Which seemed sorted the key's being mapped in the wrong location out for my UK mac keyboard running Windows 7 in VMware fusion.

Shift-2 = @ Ctrl-Alt-2 = € Shift-3 = £ Ctrl-Alt-3 = #

share|improve this answer
add comment

Windows does not support this keyboard layout without a lot of custom modification. You can install a keyboard driver for Windows from the Mac Install Disk (the one that came with the machine). But this does not include the keyboard layout.

share|improve this answer
    
But surely there's some way to reassign the keys? I notice there's KeyTweak but I don't want to move the '2' key whilst moving the '@' key! –  Anthony May 19 '11 at 17:51
add comment

I have a French keyboard and had to create the proper keyboard layout "from scratch" (well I took the nearest working keyboard layout and modified it to behave like it does under Mac OS X, including dead keys and option/shift+option combos). To that end I used the official keyboard layout creator from Microsoft.

share|improve this answer
add comment

Try changing the keyboard language from Control Panel on Windows 7 to match that of your actual keyboard, different languages map their keyboards differently. Eg. English keyboard starts QWERTY, German keyboards starts QWERTXZ

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.