Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I drag-and-drop 2 folders to the places group in finder's sidebar. Now i want to remove it. However, there was no option for remove it from side bar, although the other things (application, desktop, documents...) have the option to do so when you right-click on them.

enter image description hereenter image description here

(in short: i want to delete the folder "study" in the above screenshot)

Actually those folders are on an ntfs partition. This problem happened after i install paragon ntfs driver. It works fine before that.

Do you have any suggestion to solve this problem?

share|improve this question
    
It would be interesting to see if the folder is really in your sidebar or if the Paragon NTFS is injecting the folder systematically. User added folders can be deleted and do not reappear. Have you tried booting in safe mode (shift key held down) to try disabling the paragon software? –  bmike May 18 '11 at 12:57

4 Answers 4

up vote 1 down vote accepted

It's rather simple. Right click on the folder and click "Remove from Sidebar". screenshot

EDIT:
Since you specified that after installing the Paragon NTFS driver the folders became un-removable, i suggest that you disable the driver (from the System Preferences preference pane), restart your Mac, and see if the problem persists. If it still persists, remove Paragon NTFS and/or remove your Finder preferences. I will update my answer if disabling it does not work. sys pref pane for paragon ntfs

share|improve this answer
    
it just not have that menu. When i right-click on the folder, only "open sidebar preferences" is there. –  Chan Van Hong Le May 17 '11 at 18:16
    
@chan are you sure you're clicking the folders? "open preferences" only appear if you click on "empty space" –  Loïc Wolff May 17 '11 at 18:44
    
@Loic I have just update my questions with photos of those menus Actually it work normal before i installed paragon ntfs driver... –  Chan Van Hong Le May 18 '11 at 12:16
    
@chan I've added an answer that will most possibly solve your problem but I can't find a reason to whyit's behaving like that in the first place, yet. –  Loïc Wolff May 18 '11 at 12:25
    
@chan i've updated my answer, it may or may not work, but it sure is simpler than uninstalling it. –  user6124 May 18 '11 at 12:40

You should be able to just drag this off the sidebar, similar to how you remove a bookmark from safari or an item from your dock.

Thanks to the comment from @bmike, this changed in 10.6.7 - http://tidbits.com/article/12183

share|improve this answer
    
i can't drag it off. –  user6124 May 17 '11 at 12:24
    
i tried but nothing happend after i drag it off –  Chan Van Hong Le May 17 '11 at 18:17
1  
10.6.7 changed the behavior - you need to command drag (or option click) now as reported by tidbits - tidbits.com/article/12183 –  bmike May 18 '11 at 20:48
1  
Thank you. Looks like this news just started going around blogs, but this used to work before 10.6.7. Thank you @bmike. –  jmlumpkin May 18 '11 at 21:31

The only solution I'm seeing right now is:

  • uninstall Paragon NTFS
  • remove the folder you don't want in your sidebar
  • reinstall Paragon

I don't know why it's behaving like that, I don't exactly know how the sidebar is handled by Mac OS.

I could also be a Paragon bug, you could try to report it on their forums so they fix it.

share|improve this answer
1  
10.6.7 changed the behavior - you need to command drag (or option click) now as reported by tidbits - tidbits.com/article/12183 –  bmike May 18 '11 at 20:48

If you're running 10.6.7, dragging to remove from the sidebar changed: Try Cmd-dragging it off. (You've already tried other ways that should have worked and didn't, so I'm not hopeful, but it's worth a try).

This solution works for dead favorite folders in 10.7.2.

I have just fixed a similar problem: An OSX shortcut was pointing to a folder on an HP NAS box which had been deleted so right-click menu was only 1 item. I recreated the folder on the NAS box so I could right click on the Mac to choose from now multiple list 'Remove from sidebar'. Also install free NTFS 3G (linked on Apple site) to access native Windows HDD.

share|improve this answer
    
Thank you so much for that tip! I was having a similar problem and this work. I'm not using Paragon though...so that my make it different. –  daviesgeek Aug 19 '11 at 19:34
    
Thanks for providing this suggestion; it works perfectly on Mac OS X 10.6.8! This made me wonder, though: why does a Cmd-drag operation work where a regular drag operation doesn't? –  Chris Frederick Dec 10 '11 at 9:15
    
Yes, for NON-FUNCTIONING folders, like the initial post said, this just worked for me. –  Scott Jul 13 '12 at 13:48
    
I am using Bootcamp for using Windows on my Mac Mini. I made a short-cut to a folder in Windows partition in the sidebar - then I moved the folder in Windows partition. This resulted in the dead-link, which I was unable to remove from the sidebar. Your tip helped me remove it. Thanks! –  zeFree May 14 '13 at 6:39

protected by Community Aug 19 '11 at 20:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.