Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm doing some Rails dev, and I'm trying to get Pow running. After making the appropriate symlink, if I try to go to idealm_web.dev/ (idealm_web being the name of my Rails project), I get this:

It's gorgeous, but useless right now.

I was told that this was Apache. How do I disable this? I checked under System Preferences > Sharing, and there was no way to disable it.

share|improve this question
add comment

3 Answers 3

up vote 5 down vote accepted

If this is OS X Server (i.e. the server product, not the regular desktop OS), turn off the web service in either Server Preferences or Server Admin.

share|improve this answer
    
Yeah, it was in Server Admin - thanks! –  kivetros May 17 '11 at 13:28
add comment

You could disable the launch daemon.

I'm not an expert with launchctl but the following command should work.

sudo launchctl unload -w /System/Library/LaunchDaemons/org.apache.httpd.plist

share|improve this answer
    
This worked for me and allowed MAMP to function properly on Mountain Lion. VPN however, ceased to work. It could be my fault, but just an October 2013 update on this for others. –  nouveau Oct 25 '13 at 21:21
add comment

Turn off Web Sharing. You might have to restart. There are other ways of doing it also. Keep searching.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.