Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm running into troubles with my mac 10.9.4 because I'm unable to assign default programs for certain file types.

In my example I'm trying to assign .xml files to always be opened with TextEdit. But no matter how often I check that "Always open with" checkbox it will always be ignored. XML-files remain to be opened with Safari no matter what I can do.

I'm pretty new to mac so I have no clue where to look for help regarding this.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Not sure if you've tried this:-

Right click on an XML file and select Get Info

find the Open With section and choose TextEdit.

Underneath you should find an option for Change All

Clicking on that should change all XML files to open with TextEdit.

share|improve this answer
    
This appears to have done the trick, thanks a great deal mate! –  Sam Aug 7 at 6:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.