Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I can't seem to download or update any apps purchased in the Mac App Store. So far I've tried most of the usual troubleshooting tips found by googling the issue (deleting caches & preferences, signing out & back in, rebooting). Nothing's helped at this point. I've deleted the app from the Applications folder to try to re-install it but when I click Install, the wheel on the top left just spins for a few seconds then nothing happens & the install button reappears. I don't have any problems on a different Mac. I do have the same issue if I create another account on this Mac, so it must be a system setting somewhere...

share|improve this question
    
Have you some network security app installed like LittleSnitch ? –  Bil_fr May 12 '11 at 16:12
    
No, nothing like that. Nothing's changed on this Mac security wise since the last time I successfully used the Mac App Store. –  churnd May 12 '11 at 16:16

1 Answer 1

up vote 0 down vote accepted

I'm not sure why this worked, but I just downloaded the apps through the app store on a different Mac, then copied them over to the problematic Mac. Since then, there have been other updates applied with no problem. I'm not sure what the problem here was.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.