Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Right now i am using Microsoft PowerPoint 2011 (on my macbook pro). I am doing a project on Hispania (an old Roman province) which today is currently Spain. My spell check has switched languages to spanish (for this reason i think). However I need it to be in English because my project is not in Spanish. When i go to Tools>Language... and set it to english it ignores my change in the settings and continues to check in Spanish. Can someone please help me change my settings. Thank you

share|improve this question

3 Answers 3

Just to eliminate the possible culprits and short of reinstalling the Office. Please check in you PowerPoint in the Tools > Dictionary ... what language is indicated. If it's Spanish there try to set it to English and see if that helps. Probably after setting this you would better close entirely PowerPoint and then open it again.

share|improve this answer
    
Also check when you select some text and look into Tools > Language ... what language is there. If your language settings are English (USA) then try set it as a default for entire document. –  Tigran Khanzadyan May 11 '11 at 7:57
    
I did so, but the Spanish problem was persistent. Something to note tho is that i think it was doing it for maybe 2 or 3 slides out of the entire PowerPoint instead of the whole thing. –  luca590 Jul 18 '11 at 16:33

If you are just annoyed by the feature, you can disable it in Preferences -> Spelling by unchecking the box for Check spelling as you type:

PowerPoint 2011 - disable spell check

You can re-enable it after you're done working with this document.

If you need to keep English spell check, double-check your system language setting in System Preferences -> Language & Text -> Language. I doubt this has changed without you noticing, but there's an off chance PowerPoint may be taking its cue from this setting.

I've always had issues with multiple languages in Microsoft Office, so during installation, I disable all languages except for English. This would be a surefire solution if you don't need the extra languages, but it would require you to uninstall and reinstall Office.

Finally, I would strongly encourage you to look into Keynote ($20 through the App Store) as an alternative to PowerPoint. There would be a bit of a learning curve while you get used to it, but it's quite powerful, the interface is sleek, it runs perfectly, and I find that it's easier to make things "look nice" in Keynote than in PowerPoint. Most U.S. university classrooms will have a video hookup that you can use to run your presentation from a Mac laptop, but if it's not an option for you to run your presentations from your Mac, it can export PowerPoint-compatible files pretty well.

You're not struggling with a Microsoft operating system, so why struggle with Microsoft software?

share|improve this answer
    
Well that didnt fix the problem. However thanks for the advice, ill look into Keynote. I've herd of it before i just havnt bought it. And i didnt have to pay for my Microsoft office (word, powerpoint, excel, etc.) and it is helpful to get everything in one package. I also dont really need anything fancy. If i needed something really sleek i would use Quartz Composer instead. Thank you tho –  luca590 May 11 '11 at 5:17
    
@luca590 Disabling spell-check didn't work? Or reinstalling Office didn't work? Or did you not want to try either of those? –  Austin May 11 '11 at 5:21
    
well disabling spell check works in the since that its not telling me im making spelling mistakes, but i do need it to... just not in Spanish, and im not going to try reinstalling Office because PowerPoint is the only one ive had trouble with and i do not want to cancel all of my work and then wait to continue. I dont think its worth reinstalling –  luca590 May 11 '11 at 5:24

On those slides where spell check is working in Spanish, select the text on those slides, then do the Tools » Language » English procedure you described above. Language is formatting applied to specific text. You can mix languages sentence by sentence (or even word by word) and if it is appropriately marked, spell check will follow.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.