Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Having an odd issue. My dock is showing these strange red icons where normal numerical notifications should be. For example, Thunderbird will display a 3 when I have 3 new messages, but instead it is showing this red A? icon. This happens with all the apps in my dock that display a notification.

See attached screen shot:

enter image description here

Notice the Thunderbird icon at the top and the Printer icon at the bottom.

Anyway to get my standard notifications back?

share|improve this question
2  
Looks like a system font problem to me. Has it always been this way on your Mac? I presume you have tried restarting your computer...? –  Austin May 10 '11 at 22:20
    
No, but I don't know what triggered it. And yes, have restarted several times. –  mxmissile May 10 '11 at 22:59
2  
The glyph looks like one from the Last Resort font that is used when the requested font is not available. Most of the system UI uses Lucida Grande, but I am not sure if this also applies to your particular dock icon badges. Use Font Book to check that Lucida Grande is present, enabled, and validates correctly. Related: AD 11909. –  Chris Johnsen May 11 '11 at 1:41
    
@Chris the related question has this answer: apple.stackexchange.com/questions/11909/… –  mxmissile May 11 '11 at 18:59

1 Answer 1

up vote 4 down vote accepted

This looks like it might be a problem with a system font. Try this...

  1. Open Font Book (in /Applications)
  2. Select the "All Fonts" collection in the left-hand pane
  3. Click any font in the right-hand pane to focus that pane
  4. Select all the fonts using Edit -> Select All or Cmd+A
  5. In the File menu, click "Validate Fonts"

If any fonts are corrupt, this method should alert you to the problem.

Font Book - Validate Fonts menu option

Font Book - Font Validation window

share|improve this answer
    
This in combination with Chris's comment above solved it. Thanks! –  mxmissile May 11 '11 at 18:58
    
@mxmissile You're welcome -- glad you got it fixed! –  Austin May 11 '11 at 19:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.