Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here is a small annoyance that I have with TextMate. When I want to open a new file in TextMate when it's not running it also opens the last opened file. Now for some cases that's just nice of him to do but in most cases I end-up closing the previous file. Maybe this is a simple setup/preference issue? Any ideas?

share|improve this question
up vote 6 down vote accepted

It's not something you can set in the app preferences.

If you want to change this behavior, open Terminal.app and type

defaults write com.macromates.textmate OakDisableSessionRestore 1

This will make Textmate not remember the last session.

Change the 1 by 0 if you want the default behavior.

share|improve this answer
    
Great, thanks for the answer. – Tigran Khanzadyan May 10 '11 at 18:25
1  
This doesn't work with Textmate 2... – CharlesB Nov 24 '15 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.