Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Firefox, Safari and Chrome won't load any CSS or JS files when I open an HTTPS url, for example on Twitter, it will only load the HTML.

When I look at firebug in Firefox I get the following errors:

firebug error

  • Mac OS X version: 10.6.7
  • And all my browsers are up to date.

Anyone any idea what it could be?

share|improve this question
I've had this bug in Firefox (I don't use Chrome or Safari). I don't know what causes it, but for some reason clearing the cache fixes it for me. – michaelmichael May 10 '11 at 14:20
@michaelmichael I tried and it didn't work :( – Mathijs May 10 '11 at 14:38
Clearing the cache worked for me as well! – user118331 Mar 16 '15 at 13:12

Just a thought ... have you checked if you are using any custom Styles in those browsers? Alternatively for Safari make sure to check in the Develop menu if you have disabled styles or JS. Just to eliminate the possible culprits.

share|improve this answer
Nop never used custom styles for any browsers. And I checked if I disabled styles/js files but i didn't disabled them either. – Mathijs May 10 '11 at 15:24
OK, how about adblock? Are you using some kind of adblock on those browsers? Just looked at your posted screenshot and it seams that google analytic was also blocked. Maybe you are using some system-wide network filtering that you've forgot that you have? – Tigran Khanzadyan May 10 '11 at 15:29
Thx for you help – Mathijs May 23 '11 at 9:16
Great, so at least it's sorted-out now:) Happy surfing. – Tigran Khanzadyan May 23 '11 at 9:21
+1 it was the Developer menu interfering with styles for me. "Reset Safari" should reset the developer menu too. – Jano Jan 24 '12 at 12:18
up vote 1 down vote accepted

My system date wasn't correct, it was set 2 months back. When I changed it to the date of today my problem was solved.

share|improve this answer

I had the same issue in all the browsers. Clearing the cache solved this for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.