Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I updated my 3rd gen iPod Touch to 4.3.3, and now almost none of the apps will run - they appear to start, and then exit back to the desktop.

A double-tap on the home button shows them running, but switching to them produces the same results.

Is this a known issue? Any way to fix it?

share|improve this question
    
Try rebooting your iPod Touch by holding down the power and home buttons until you see the Apple logo. (Keep holding them through the part where it says "slide to power off".) Did that help? –  Austin May 8 '11 at 20:58
    
Nope, I tried that and the behavior was the same. –  chris May 8 '11 at 22:09
    
What settings were there in the iPhone before the update? –  user6124 May 9 '11 at 1:15
add comment

2 Answers

up vote 1 down vote accepted

I would recommend following these steps to restore your iPod Touch: http://support.apple.com/kb/ht1414

In short, when you connect your device, go to the device's Summary tab in iTunes and click the Restore button. It should prompt you to back up your device first.

share|improve this answer
    
A restore seems to have fixed it. However, it seems that the ipod (ok, it wasn't really mine - it's my sons) has been bounced between two profiles. I wonder if there's something new in 4.3.3 that validates that the app was purchased by the current user? –  chris May 11 '11 at 2:15
add comment

I encountered this problem, and it seems to be solved after entering the app store, and clicking Update All.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.